# Table of Contents

1. Introduction .................................................................................................................. 1
   1.1. About Cartographica ............................................................................................... 1
   1.2. Projections, Coordinate Systems, and Datum ....................................................... 1
   1.3. Features ................................................................................................................. 1
   1.4. Layers .................................................................................................................. 2
2. Getting Started with Cartographica .............................................................................. 3
   2.1. Installing Cartographica ......................................................................................... 3
   2.2. Updating Cartographica ......................................................................................... 4
   2.3. Interface Overview ............................................................................................... 5
       2.3.1. Utility Windows .............................................................................................. 7
   2.4. Drag and Drop throughout Cartographica ................................................................ 11
   2.5. Undo everywhere ................................................................................................. 11
3. Importing Data into Cartographica ............................................................................. 12
   3.1. Overview ............................................................................................................. 12
   3.2. Importing Vector Files ........................................................................................ 14
       3.2.1. Characters and Encodings ............................................................................. 15
   3.3. Importing Raster Data ......................................................................................... 15
   3.4. Importing Text Files and Table Data ................................................................... 16
       3.4.1. The Import Map ............................................................................................ 16
       3.4.2. Importing data from Text and DBF files ....................................................... 17
   3.5. Acquiring Database Data .................................................................................... 18
   3.6. Joining Non-Geospatial Data ............................................................................. 20
   3.7. Acquiring GPS Data ........................................................................................... 21
   3.8. Acquiring Images from Web Map Servers (WMS) ................................................. 23
4. Exploring Data ........................................................................................................... 27
   4.1. Zooming In and Out of Maps ............................................................................. 27
   4.2. Selecting Data and Using the Identify Tool ............................................................ 29
   4.3. Using the Pan Tool to Move a Map ..................................................................... 29
   4.4. Data Tooltips ..................................................................................................... 32
   4.5. Measuring Distance and Area .......................................................................... 30
   4.6. Using the Data View ......................................................................................... 29
   4.7. Adding, Removing, and Renaming Columns ...................................................... 34
   4.8. Using the Selection Window .............................................................................. 35
   4.9. Using the Point Data Window .......................................................................... 36
   4.10. Additional Layer Info ....................................................................................... 37
5. Working With Layers .................................................................................................. 39
   5.1. Using the Layer Stack ......................................................................................... 39
   5.2. Using the Layer Info Window ............................................................................ 40
   5.3. Filtering on Layers Using the Filter Box .............................................................. 40
   5.4. Adding and Removing Layers .......................................................................... 41
   5.5. Adding a New Layer Based on a Data Selection ................................................. 42
   5.6. Merging Layers ................................................................................................... 42
   5.7. Masking Data for Analysis Layers .................................................................... 43
   5.8. Setting Layer Projection .................................................................................... 44
       5.8.1. Reprojecting Layers .................................................................................... 46
   5.9. Referenced Data ................................................................................................. 47
6. Working With Styles .................................................................................................. 48
   6.1. Styling Vector Layers .......................................................................................... 49
       6.1.1. Point Styles .................................................................................................... 50
       6.1.2. Line Styles .................................................................................................... 53
       6.1.3. Polygon Styles ............................................................................................. 53
List of Procedures

2.1. Installing Cartographica from the disk image ................................................................. 3
2.2. Changing your auto-update preferences ........................................................................ 5
2.3. Manually updating Cartographica .................................................................................. 5
3.1. Importing Vector Files .................................................................................................. 14
3.2. Importing Raster Files .................................................................................................. 15
3.3. Importing files containing coordinate data ................................................................. 17
3.4. Importing files containing address data ....................................................................... 17
3.5. Acquiring coordinate data from a database ................................................................. 19
3.6. Acquiring data from a database .................................................................................... 19
3.7. Acquire data directly from a GPS .............................................................................. 22
3.8. Acquire data from a WMS Server .............................................................................. 23
3.9. Add New WMS Server ............................................................................................... 25
3.10. Removing a WMS Server ......................................................................................... 25
3.11. Editing a WMS Server .............................................................................................. 25
4.1. Specifying Data Tooltip information ........................................................................... 29
4.2. Sorting the Data View ................................................................................................. 33
4.3. Re-ordering columns in the Data View ......................................................................... 33
4.4. Editing data in the Data View .................................................................................... 33
4.5. Adding Columns to a Layer ....................................................................................... 34
4.6. Removing Columns from a Layer ............................................................................... 34
4.7. Renaming Columns in a Layer ................................................................................... 35
5.1. Showing and Hiding layers ......................................................................................... 39
5.2. Adding New Layers .................................................................................................... 41
5.3. Removing Layers ....................................................................................................... 41
5.4. Masking an analysis layer .......................................................................................... 44
5.5. Removing an analysis layer mask ................................................................................ 44
5.6. Bringing External data into the Mapset ....................................................................... 47
5.7. Flattening a Mapset .................................................................................................. 47
6.1. Opening the Style Editor ............................................................................................ 48
6.2. Setting the Symbol for a Point layer .......................................................................... 51
6.3. Using a Font Character as a Symbol for a Point Layer .............................................. 52
6.4. Using an Image File as a Symbol for a Point Layer .................................................... 52
6.5. Using Pictures as a symbol ....................................................................................... 52
6.6. Add a label to a style ................................................................................................. 54
6.7. Applying a palette of colors to a set of styles .............................................................. 56
6.8. Temporarily disable all styles for a layer ................................................................... 56
6.9. Adjusting a Raster Layer’s opacity ............................................................................. 57
6.10. Changing a Raster Layer’s opacity ........................................................................... 57
6.11. Constraining palette range ...................................................................................... 58
6.12. Setting automatic palette range .............................................................................. 58
6.13. Changing the background color of a map .................................................................. 58
6.14. Changing the default background color for new maps ............................................ 58
7.1. Trimming a Map to a layer’s extent ............................................................................ 60
7.2. Trimming a Map to a feature’s extent ....................................................................... 60
7.3. Trimming a Map to a feature’s area .......................................................................... 60
8.1. Creating a convex hull ............................................................................................... 66
8.2. Create Buffers ........................................................................................................... 67
8.3. Count points in polygons .......................................................................................... 68
8.4. Adding Coordinates Columns for Points to the layer ............................................... 69
8.5. Adding an Area Column to the layer ....................................................................... 69
8.6. Adding a Length Column to the Layer .................................................................... 69
8.7. Adding a Midpoint Coordinates Column to the Layer .......................................................... 69
8.8. Adding a Centroid Coordinates Column to the layer .......................................................... 69
8.9. Adding a Column showing the Distance to Nearest Feature .................................................. 70
8.10. Configuring Bing Geocoder .......................................................................................... 72
8.11. Preparing to geocode with TIGER data ............................................................................ 72
8.12. Configuring Internal Geocoding .................................................................................... 73
8.13. Geocoding your address book ......................................................................................... 74
8.14. Importing photos coded with geospatial data ................................................................. 75
8.15. Importing photos by matching photo times and GPS tracks ............................................... 75
9.1. Merging Raster Layers Automatically .............................................................................. 77
9.2. Merging Raster Layers manually ..................................................................................... 77
10.1. Editing an existing feature ............................................................................................. 79
10.2. Adding a New Feature ................................................................................................ 81
10.3. Changing Edit Backdrop Color ................................................................................... 81
10.4. Precision Editing Features in the Point window ............................................................... 81
10.5. To merge selected features into one .............................................................................. 82
10.6. Splitting a multi-part feature into separate features ....................................................... 82
11.1. To export an entire map ............................................................................................... 84
11.2. Setting display fields for KML Export .............................................................................. 85
11.3. Setting the name of features for KML Export .................................................................... 86
11.4. Exporting an individual layer or selection ....................................................................... 87
11.5. Creating a web map ..................................................................................................... 88
11.6. Export a Map as Picture ............................................................................................... 89
12.1. Quick-Printing the current map ..................................................................................... 90
12.2. Create a new Map Layout ............................................................................................. 90
12.3. Placing a Map into the Map Layout Window ................................................................. 92
12.4. Changing the visible Map area in Map Layout .............................................................. 93
12.5. Including or excluding layers from a Map ..................................................................... 94
12.6. Adding a scale box to Map Layout ............................................................................... 94
12.7. Customizing a scale box .............................................................................................. 94
12.8. Adding a legend to Map Layout ..................................................................................... 95
12.9. Including or excluding layers from a Legend ................................................................. 96
12.10. Adding a compass to Map Layout ................................................................................. 96
12.11. Adding a Text to Map Layout ..................................................................................... 96
12.12. Removing Map Layout objects ................................................................................... 98
13.1. Creating a Column Formula ....................................................................................... 99
14.1. Create a new palette ................................................................................................... 108
14.2. Removing a palette ..................................................................................................... 109
14.3. Changing a color in a palette ...................................................................................... 109
14.4. Switching between ramp and segmented palettes ....................................................... 110
14.5. Reversing the colors in a palette ................................................................................ 110
14.6. Pasting a color brewer palette .................................................................................. 110
Chapter 1. Introduction

1.1. About Cartographica

Cartographica™ is a Geographic Information System (GIS) package for the Macintosh. It is used to create, analyse and present geospatial data.

1.2. Projections, Coordinate Systems, and Datum

Mapping the Earth requires a mathematical projection that enables us to view a spherical body on a two-dimensional surface. The problem of representing a sphere on a 2-D surface is that in almost all cases at least some part of the map becomes distorted due to the curvature of the Earth. To account for this problem, we have created Geographic Coordinate Systems (GCS) and datums to better represent our objects of study. Geographic Coordinate Systems contain X, Y, and Z data that provide standardized locations of objects on Earth. X coordinates generally describe longitudinal data, Y coordinates describe latitudinal data, and Z coordinates typically describe an elevation. Not all GCSs are the same once projected on a map because they are based on different datums that allow for specificity in mapping.

Geographic Coordinate Systems must be defined by a datum, which are sets of reference points on the Earth’s surface. Because there are literally an infinite number of ways to view the Earth, it is critical to account for distortion in specific areas. For example, if we are studying the dispersion of moose in Alaska then we would likely not want to use the same datum in a study of kangaroo in Australia. Using specific datums allows us to get the most accurate depiction of the location that we are studying.

Generally, GIS programs such as Cartographica can quickly translate datums if they are originally projected on different or non-specific datums.

A common translation that users might encounter is if data isn’t projected using the WGS 84 datum. WGS 84 or World Geodetic System (1984), is a standard datum for many GIS and GPS devices, and is the only world wide datum. A user that brings in data collected from a GPS device and then attempts to map the data with a specific datum, might find that their map is not accurately projected. Cartographica can account for this by translating data to an already established datum like WGS 84. We have incorporated NTv2 support to provide accurate mapping between NAD27 and NAD83.

1.3. Features

Cartographica’s most basic unit of information is a Feature. A feature is a geometric container for information. Usually, we represent a feature as a point, line, polygons, or imagery. Point data is the most basic and represents a location in 2d or 3d space. Line data is the next most complex and represents a series of points in a particular direction which are connected. Polygon (also sometimes called Area) data is the most complex data and represents a series of points which surround an area, optionally containing "holes" that cut areas out.
1.4. Layers

In Cartographica, data is organized into Layers. A Layer consists of one type of data (point, line, area, or imagery), and contains one or more features of each type. Each of these features usually contains geospatial information (one or more sets of X,Y and possibly Z coordinates) as well as optional reference data that describes characteristics of the features in the layer. It is the attachment of the reference additional data to the geospatial information that makes a GIS like Cartographica so powerful. By using the geospatial data, correlations can be made between information in the reference data, leading to informative maps and insightful data analysis.
Chapter 2. Getting Started with Cartographica

2.1. Installing Cartographica

Cartographica is delivered over the internet in a standard Macintosh disk image, which is just a way to package Macintosh programs and files so that they are not harmed during transport across the Internet.

For those who are not familiar with this kind of software delivery, it can be a bit confusing. The disk image acts just like a CD inserted into your Macintosh, but without the physical media. Once the disk image shows up on your computer, the contents only stay there until you Eject the disk image from the Finder.

Although it is possible to run Cartographica from the disk image, it is not suggested, as it can become confusing to have to reload the disk image (and re-accept the license agreement) each time you run the program.

The Cartographica disk image contains the license agreement and may contain additional information along with the program itself.

Procedure 2.1. Installing Cartographica from the disk image

1. Locate the Cartographica disk image in the Finder

   If you have just downloaded it from the MacGIS.com site [http://www.macgis.com], the disk image will be inside of your default download folder.

2. Double-click on the disk image file to open it

   The Cartographica license agreement window will appear. Read through the agreement until you are satisfied that we aren't doing anything bad.

3. Click Accept to continue

   The contents of the Cartographica disk image should now be visible in the Finder.
4. Drag the Cartographica program icon from the disk image into your Applications folder.
   You can place Cartographica almost anywhere you like, but the standard practice on the Macintosh is to use the Applications folder.

Cartographica is now installed and ready to run.

5. Choose Go → Applications in the Finder to open the Applications folder.

6. Optionally, drag the Cartographica icon from the Applications folder to the Dock if you want to be able to access Cartographica quickly from the dock.

7. Double-click on Cartographica in the Applications folder or click on Cartographica in the dock to get started.

### 2.2. Updating Cartographica

Cartographica has a built-in update service that helps to make sure that you have the most recent updates to the software. When you run Cartographica for the second time, you will be asked if you would like to let Cartographica check for updates. We strongly suggest that you allow Cartographica to do this check as it will keep you informed of any important bug fixes and feature additions.
You can always opt in or out of the automatic update process later by changing your update preferences. Even if you opt out of the auto-update process, you can still use the updating mechanism in Cartographica to check for updates manually.

**Procedure 2.2. Changing your auto-update preferences**

1. Choose Cartographica → Preferences… to bring up the Cartographica Preferences window

2. Check Automatically Check for Updates to enable the auto-updater and uncheck it to disable the feature.

3. Advanced users may wish to subscribe to the Development or Beta versions of the software in order to help test future features in Cartographica. Although it is suggested that most people leave the update setting at Release, you can change it to Beta or Development if you are instructed to do so.

4. Optionally check Sends System Profile Information if you want to help out ClueTrust by sending along some basic (non-identifying) statistical data about your computer when you check for updates.

**Procedure 2.3. Manually updating Cartographica**

1. Choose Cartographica → Check for Updates…

   If there is a new version of Cartographica available, you will be presented with information about changes in the updated software and given the option to install it or to defer until later.

2. Click Install Update to begin the update process

   Cartographica will download the new version while you work and then prompt you later to install the new copy.

3. Click Install and Relaunch to shut down Cartographica, install the new version, and restart the program.

   Once Cartographica restarts, you're ready to use the new version.

**2.3. Interface Overview**

When you initially open a Cartographica map the Map Window appears. Figure 2.2, “Main Cartographica window” shows that window with a map already loaded in it. This window is the centerpiece of Cartographica and where most of the work is done. In the figure we have shaded various sections of the window for purposes of explaining the layout and function of each of the sections.
Figure 2.2. Main Cartographica window

Toolbar

The Toolbar at the top of the window provides access to often-used functions in Cartographica.

As with all toolbars on the Macintosh, it is optional and may be hidden, resized, or changed by using the Toolbar Button in the upper right corner of the window or View → Customize Toolbar…

Layer Stack

The layer stack shows the list of all layers in the map document and provides an easy way to re-order layers, change styles, and show or hide individual layers.

The selection in the Layer Stack provides guidance to the Map View and Data View as to which data is selectable.

**Warning Triangles in the Layer Stack**

You may see a warning triangle in the right side of the Layer Stack. If this happens, click on the triangle to find out what the problem
is with the layer. The most common cause of the warning triangle is a layer that has no valid CRS.

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map View</td>
<td>The powerhouse of Cartographica, the Map View shows your geospatial data in context with all of the visible layers.</td>
</tr>
<tr>
<td>Data View</td>
<td>The Data View is used to show and edit data for the layer selected in the Layer Stack.</td>
</tr>
<tr>
<td>Zoom</td>
<td>The Zoom area is used to control and display zoom information about the Map View. The Zoom Dial can be used like a slider to zoom out (slide up) or zoom in (slide down). Below the Zoom Dial is the Zoom Factor Box which shows the percentage zoom in effect right now. Typing a new value in this box will change the zoom level directly.</td>
</tr>
<tr>
<td>Advanced Filters</td>
<td>The Advanced Filters area is not always visible, but once you have started performing a filter operation (using the Filter box in the Toolbar), it will pop into view. Advanced filters provides for boolean operations so that you can search and filter on more than one variable at a time.</td>
</tr>
</tbody>
</table>

### 2.3.1. Utility Windows

Cartographica uses Utility Windows (sometimes called palettes) that float above other windows in order to provide access to more information about the current context. The content of these windows is synchronized to the current Map Window, so if you have more than one Map open, they will change when you switch back and forth between the Map Windows. Each of the Utility Windows is accessible via the Window menu.

**Measurements**

The Measurements Window provides information about the position directly underneath the cursor or the current selection when dragging. See Section 4.5, “Measuring Distance and Area” for details on how to bring up and use the Measurement window.

![Figure 2.3. Measurements Window](image)
Layer Info

The Layer Info Window provides information about the layer currently selected in the Layer Stack. Changes made in this window affect the data in the selected layer.

Legend

The Legend Window provides a quick reference to all of the layer styles in the current Map.

Figure 2.4. Layer Info Window

Figure 2.5. Legend Window
Image Viewer  
The Image Viewer Window provides an enhanced view of any pictures referenced by a feature using the **Picture** item in the Style window.

![Image Viewer](image)

**Figure 2.6. Image Viewer**

Selection Info  
The Selection Info Window provides a concise view of all selected objects. On the left is a list of all features currently selected and the layer that they belong to. On the right is the information about the selected feature.

![Selection Info Window](image)

**Figure 2.7. Selection Info Window**
Point Data The Point Data Window provides a detailed view of all points in the geometry of the selected feature. On the left is a list of all parts (all geometries have at least one part if they have any points). On the right is a list of all points in that part. Point information may be edited manually in this window. It is important to remember that all coordinates in this window are in the layer's coordinate system, not in the map's coordinate system.

Figure 2.8. Selection Info Window

Color Palettes The Color Palettes Window provides access to color palettes that Cartographica can use for vector and raster data. This window provides for selection of palettes as well as editing. For more information, see Chapter 14, Color Palettes

Figure 2.9. Color Palettes Window
Symbol Browser  The Symbol Browser Window provides access to all built-in symbols in Cartographica, for use when changing styles for point layers. For more information, see Figure 2.10, “Symbol Browser Window”

Figure 2.10. Symbol Browser Window

2.4. Drag and Drop throughout Cartographica

Drag and drop is used extensively throughout Cartographica where it is reasonable. Usually it provides a shortcut to some functionality elsewhere in the program’s menus and windows. A few of these drag and drop shortcuts are elaborated here, but if it makes logical sense to drag and drop something it will most likely work.

• Drop vector or raster files on the map window to import them.
• Drop picture files that have lat & long on them into the window and they’ll be plotted in a new layer on the map.
• Drag layers to reorder them in the layer stack.
• Drop one layer on another to copy the styles.
• Drop a color swatch from the color picker onto the map background and change the background.
• Drag a layer from one map window to another in order to create a new copy of that layer in the map you drop it on.
• Drop a map icon (grabbed from the title bar) into a Map Layout document to add a map copy there.
• Drop color maps onto analysis layers to change the color map.

2.5. Undo everywhere

Since one of Cartographica’s key goals is to help you understand your data better, we believe it is important to be able to quickly experiment with new ways of looking at your data. To help with this, Cartographica is replete with undo and redo capabilities, making it possible to experiment with new ideas to your heart’s content without having to fear that you’ll do something you can’t undo.
Chapter 3. Importing Data into Cartographica

3.1. Overview

Cartographica is commonly used to provide visual interpretations and facilitate analysis of geospatial data. Most data that is analyzed in Cartographica is not created or produced internally. Instead, users typically add data into the maps that have been previously obtained from entities like government agencies or private businesses.

Cartographica imports data from many sources. Using algorithms created by the ClueTrust team and by the folks who create, maintain, and contribute to Geospatial Data Abstraction Library (GDAL), Cartographica is able to bring in data from an enormous number of sources, including (but not limited to):

- ESRI® Shape Files
- MapInfo® MAP Files
- USGS DEM and DRG files
- Ordnance Survey and GML files
- Personal Geodatabase
- GPX files
- KML files

The types of files you will use as source data will vary depending upon what you have available and what specific needs you have. The general kinds of data that Cartographica can import are:
**Vector Files**
Files that contain referenced data in numeric form that can be scaled up to the resolution of the data. Vector data includes data such as points, lines, and polygons.

**Raster Files**
Files that contain picture information (such as an orthophoto) or data sampled at a specific resolution as point sources. Raster Data includes data such as pictures or satellite images.

**Text Files (or Table Data)**
Text files can be used to bring in simple geospatial data (such as points) or to merge in adjunct information, and usually contain lists of values (or fields). Table data include comma separated values (csv) and tab separated values (tsv). Text/Table import supports a variety of character sets, including UTF-8, WindowsLatin1, and others. If you are using a non UTF-8 character set, it’s best to set that when opening the file.

**GPS Data**
GPS Devices provide location information sampled at a particular point in time. For most purposes, these are waypoints (point sources marked by the GPS User) and tracks (timestamped record of the device’s travels).

**Database Information**
Databases can contain many of the types of data already described above. Although they usually most similarly resemble Text Files (fields of data and possibly simple geospatial data), some database formats contain complex geometry.

**Figure 3.1. Common File Types**

For many applications, a single Cartographica Map Set will contain multiple layers loaded from more than one type of file or other data source. For example, vector data is often used with an underlying raster image in order to show it in the context of an aerial photo.

With Version 1.2 of Cartographica, we have introduced the ability to use dynamic maps as well as the static maps that we have described so far. These can take on a number of different forms, including vector data and raster imagery and can come from a variety of sources.
**Bing Maps**

Bing Maps provides images for use as background maps in Cartographica (and other programs as well as many websites). The images available include satellite imagery, roads, and a hybrid combination of the two.

**OpenStreetMap**

OpenStreetMap is a service and an informal protocol. Although the original OpenStreetMap is a service run from the UK which provides street-level map data which has been put together on a volunteer basis around the world, the protocol used by OpenStreetMap has now become an ad hoc standard and is also used by other systems.

**Web Map Servers**

Web Map Servers are servers that use the WMS protocol, defined by the Open Geospatial Consortium (OGC). This protocol is widely used in private and public systems and a growing amount of data is available using it. WMS data is by nature raster data, meaning that it carries no attributes with it. It is most commonly used as background imagery or to offload complex overlay tasks to a server so that clients do not need to merge multiple layers.

**Web Feature Servers**

Web Feature Servers are servers that use the WFS protocol, also defined by the OGC. This protocol is widely used in private and public systems and a growing amount of data is available using it. Unlike WMS, WFS serves data which is, by nature, Features and therefore vector. Data from these types of services may be used in analysis and more flexibly understood.

---

**Figure 3.2. Server-Based Formats**

---

### 3.2. Importing Vector Files

Vector files contain geospatial information and often have accompanying reference data that describes the data in the files.

**Procedure 3.1. Importing Vector Files**

1. Choose **File → Import Vector Data**.
   
   The standard file chooser will come up

2. Select the vector file to import and click **OK**
   
   If you have more than one file to import, you can either select multiple items during this import.

   The projection of the map will be set by the first layer added, and projections of each file will be recorded as loaded to make sure each layer is reprojected correctly.

   Vector imports are quite straightforward and usually do not require any additional decision making, but in the event that your data is in a non-standard character format, you can override the automatic character format detection and select it explicitly. Data loaded from these files is inserted into the Cartographica system as points, lines, or polygons (as appropriate) and any per-feature data is added as necessary.

3. Once you have imported the data, choose **Layer → Set Layer Projection**... to confirm that the coordinate system of the data is accurately selected.
3.2.1. Characters and Encodings

For shapefiles, Cartographica attempts to figure out what kind of encodings are used in the files by first checking for a "cpg" file (which will be written by ESRI's products when attempting to write out files that don't conform to specifications in the DBF format), then looking at the LDID inside of the "dbf" file itself.

If that fails, the presumption is that the data is in ISO Latin 1, which is the default for older files. We have confirmed success working with UTF-8 and many other character sets, but since not all characters are represented in the schemes other than UTF-8, there is the potential for losing some data when exporting to other character formats.

In the case of GML and KML, the imported data is presumed to be Unicode UTF-8 (unless specified otherwise in the file itself, since there exist ways to do that in these XML-based formats). Other file types may use specific characters set in the import window.

3.3. Importing Raster Data

Raster files contain data whose form is that of samples in some form of matrix. The most common example of this kind of file is an orthophoto image file (such as a JPEG). In these files, the data provided are color information and the matrix is the frame of the picture. Cartographica supports the efficient use of large Raster files (tested up to 5GB).

Raster files can take on many forms. Some of the more common forms you may want to import include:

- USGS DRG files consisting of georeferenced photo data
- DEM (Digital Elevation Model) Files contain elevation data in a point matrix
- Orthophotos - aerial photos that are geometrically corrected to make the scale uniform

Procedure 3.2. Importing Raster Files

1. Choose File → Import Raster Data.

2. Select the file to import and click Open.

   If you have more than one file to import, you may select multiple items during this import.

   Some raster data is not georeferenced and may not be positioned correctly on the map. See ???? to solve this problem.

3. Once you have imported the data, choose Layer → Set Layer Projection to confirm that the coordinate system of the data is accurately represented (including Datum and Projection).

Once the data is imported, you can use the dedicated layer style window for raster layers to display and change the color palette applied to the raster data. This is particularly useful for files such as DEM, in which samples are made up of floating-point or integer information instead of colors. In addition, by using the Tools → Merge Selected Raster Layers you can place more than one dataset in the same layer, forcing them all to use the same palette over the same range. In automatic mode, the range is the range of all datasets in the layer. In manual mode, the range is determined by the user.
3.4. Importing Text Files and Table Data

Cartographica can import text files that contain tables as geospatial and data sources. Cartographica can use text files (either CSV, TSV or DBF) to provide three different types of data:

- Coordinate data: Coordinate data contains either X,Y coordinates or latitude and longitude.
- Address data: Address data contains postal addresses.
- Tabular data: Tabular data contains no geospatial information.

Because there is a great variety of sources and types of data which originate in non-geospatial files, Cartographica has a few mechanisms that are used consistently in many of our importing systems.

3.4.1. The Import Map

Cartographica uses the Import Map when importing tabular data (Section 3.4.2, “Importing data from Text and DBF files”) and importing from databases (Section 3.5, “Acquiring Database Data”). It serves two purposes: first to determine how to associate new data with an existing or new layer, and second, to determine how to relate the imported data geospatially to the rest of the data in the map.

Figure 3.3. Import Map

The left side of the Import Map window is used to define the relationship between fields within the file or database that is being imported and the layer that they are being imported into. The meaning of each column is detailed here.

Field Name

The name of the field being imported. Based either on the initial line of the file or the database source that the data is coming from.
Importing Data into Cartographica

| Type | The kind of data being imported (String, Number, Date, etc). This is determined either directly from the import source or by heuristic. |
| Map To | Determines which column this field will map to in the resultant layer. When set to New Column, a new column with this name will be added to the table. Special values for geocoding and Coordinate import are also available. Existing fields are listed if the target layer is not new. - Do Not Import - tells Cartographica not to import this field at all. |
| Key | The Key field is only used for the Join style of importing, and we be detailed in section REFERENCE. When the Key box is checked, the corresponding relationship between the imported field and the Map To field is used to determine which feature to associate a row from the data file with. |

3.4.2. Importing data from Text and DBF files

Procedure 3.3. Importing files containing coordinate data

1. Choose File → Import Table Data....
   The standard file chooser appears.

2. Select the location of the text or table file you want to import and click Open.
   The Import Map window appears and describes the format of the file and requests that you determine how it should interpret the data as it is read.

3. Using Target Layer select an existing layer to append the data to, or choose New Layer.

4. Choose Coordinates from the right hand set of tabs in the window. This will enable coordinate import mode.
   Because you are in coordinate import mode, the choices in your Map To column include X (or longitude), Y (or latitude), Z (or altitude) and M (or time) along with the standard options of - Do Not Import -, New Column, and any columns that exist in your selected target layer.

5. Using the Import Map (as described in Section 3.4.1, "The Import Map", map the incoming data fields to your selected layer, making sure that you map at least one column to the X and Y coordinates. Without both of these, Cartographica cannot place the data on the map.

6. Click Import to import your data into the map.
   Cartographica will read the data from the file, interpret the columns to the best of its abilities and store them into the requested layer.

7. Once you have imported the data, choose Layer → Set Layer Projection to confirm that the coordinate system of the data is accurately represented.

Procedure 3.4. Importing files containing address data

Before importing address data, the geocoder must be appropriately configured. This is an easy process, outlined in Section 8.7, “Geocoding Addresses”.

1. Choose File → Import Table Data....
   The standard file chooser appears.
2. Select the location of the text or table file you want to import and click **Open**.

   The Import Map window appears and describes the format of the file and requests that you determine how it should interpret the data as it is read.

3. Using **Target Layer** select an existing layer to append the data to, or choose **New Layer**.

4. Choose **Geocode** from the right hand set of tabs in the window. This will enable address geocoding mode.

   Because you are in address geocoding mode, the choices in your **Map To** column include **Address 1** through **Address 4**, **City**, **State** **ZIP**, **ZIP+4**, and **Country** along with the standard options of **Do Not Import**, **New Column**, and any columns that exist in your selected target layer.

5. Using the Import Map (as described in Section 3.4.1, “The Import Map”), map the incoming data fields to your selected layer, making sure that you map at least one column to **Address 1**. If it is the only column specified, then it will be presumed to have a full address in it.

6. If necessary, fill in one or more of the **City**, **State**, or **Country** boxes in the right pane. These act as defaults for the geocoder in the event that there are no columns that match. Often city data is delivered with only the street portion of the address, and these fields can be used to limit the search to that particular city.

7. Click **Import** to import your data into the map.

   Cartographica will read the data from the file, interpret the columns to the best of its abilities using the geocoding specifications and store them into the requested layer.

8. Once you have imported the data, choose **Layer → Set Layer Projection** to confirm that the coordinate system of the data is accurately represented.

### 3.5. Acquiring Database Data

Acquiring database information works similarly to Section 3.4, “Importing Text Files and Table Data”, except that instead of reading the data from a data file, it is read from a database. By using Open Database Connectivity (ODBC) Cartographica is compatible with a wide variety of file formats and database systems (including, but not limited to: Filemaker Pro, Oracle, MySQL, PostgreSQL, and many others).

As with importing tables, Cartographica uses the Import Map (Section 3.4.1, “The Import Map”) in order to map incoming data to coordinates or addresses.

Due to the nature of the ODBC drivers on the Macintosh, there are some compatibility issues with older drivers under 10.6 and certain combinations of data and drivers. If you plan to import data with ODBC, please visit the ClueTrust Knowledgebase and read the article on ODBC.

The trickiest part about reading data from a database using ODBC is setting up the ODBC connection on the system. Although that task is beyond the scope of this manual, there are good documents available for doing this from the vendors of the connection software. In particular, if you are using FileMake Pro, they have a good site, and Actual Technologies provides excellent support for their crop of 64-bit drivers.

As with tables, database data can be interpreted in a variety of ways when it is imported to the system. Coordinate imports, geocoding, and joins are all available for data from databases.
Procedure 3.5. Acquiring coordinate data from a database

1. Choose File \(\rightarrow\) Acquire Database Data…

   The Data Source window appears.

   ![Figure 3.4. Data Source Window](image)

2. Select a **Data Source** and enter a **User Name** and **Password** if required.

3. Click **Connect** and Cartographica will retrieve and present a list of tables.

4. Choose a table from the **Table** menu to import and click **Select**.

5. Using **Target Layer** select an existing layer to append the data to, or choose **New Layer**.

6. Choose **Coordinates** from the right hand set of tabs in the window. This will enable coordinate import mode.

   Because you are in coordinate import mode, the choices in your **Map To** column include **X** (or longitude) **Y** (or latitude), **Z** (or altitude) and **M** (or time) along with the standard options of **Do Not Import**, **New Column**, and any columns that exist in your selected target layer.

7. Refer to Section 3.4.1, “The Import Map” for details on how to map fields with the Import Map window.

8. Once you have imported the data, choose **Layer \(\rightarrow\) Set Layer Projection** to confirm that the coordinate system of the data is accurately represented.

Procedure 3.6. Acquiring data from a database

1. Choose File \(\rightarrow\) Acquire Database Data…

   The Data Source window appears.

2. Select a **Data Source** and enter a **User Name** and **Password** if required.

3. Click **Connect** and Cartographica will retrieve and present a list of tables.

4. Choose a table from the **Table** menu to import and click **Select**.
5. Using **Target Layer** select an existing layer to append the data to, or choose **New Layer**.

6. Choose **Geocode** from the right hand set of tabs in the window. This will enable address geocoding mode.

   Because you are in address geocoding mode, the choices in your **Map To** column include **Address 1** through **Address 4**, **City**, **State ZIP**, **ZIP+4**, and **Country** along with the standard options of **- Do Not Import -**, **New Column**, and any columns that exist in your selected target layer.

7. At this point, you will be presented with an Import Map window. Please refer to Section 3.4.1, “The Import Map” for details on how to use the Import Map window.

8. Refer to Section 3.4.1, “The Import Map” for details on how to map fields with the Import Map window.

9. Once you have imported the data, choose **Layer → Set Layer Projection** to confirm that the coordinate system of the data is accurately represented.

### 3.6. Joining Non-Geospatial Data

At times it may be necessary to add data to an existing layer by cross-referencing that data with another table. Cartographica does this by matching columns in an existing layer with data from a file and adding the new data to features which match. This operation is called a join in database parlance and by some GIS packages, performing a join between an existing layer and new data based on matching data in both places.

To join data, use the **Map To** column to specify the destination column for the imported data (or **New Column** if you want to add a new column for the imported data). Matching criteria is specified by checking the **Key** box next to a column. Checking more than one **Key** box will only add the data when all Key fields match.

As an example, here is some existing Polygonal data (Example Data A) for three Counties that exist in two different States:

**Table 3.1. Example Data A - Original Data**

<table>
<thead>
<tr>
<th>County Name</th>
<th>State Name</th>
<th>Area (Sq KM)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floyd</td>
<td>Kentucky</td>
<td>1,020</td>
</tr>
<tr>
<td>Loudon</td>
<td>Virginia</td>
<td>1,347</td>
</tr>
<tr>
<td>Floyd</td>
<td>Virginia</td>
<td>989</td>
</tr>
</tbody>
</table>

(Note that Floyd counties exist in both states)

Here is the data you want to join with the above data (Example Data B):

**Table 3.2. Example Data B**

<table>
<thead>
<tr>
<th>County Name</th>
<th>State Name</th>
<th>1990 Census Population</th>
<th>2000 Census Population</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barren</td>
<td>Kentucky</td>
<td>38,033</td>
<td>30,033</td>
</tr>
<tr>
<td>Adair</td>
<td>Iowa</td>
<td>8,243</td>
<td>8,244</td>
</tr>
<tr>
<td>Floyd</td>
<td>Kentucky</td>
<td>42,441</td>
<td>40,441</td>
</tr>
<tr>
<td>Fairfax</td>
<td>Virginia</td>
<td>1,077,000</td>
<td>1,099,000</td>
</tr>
<tr>
<td>Loudon</td>
<td>Virginia</td>
<td>169,599</td>
<td>269,599</td>
</tr>
</tbody>
</table>
Here is the result of performing the Join of Example Data B to Example Data A using County Name and State Name columns as keys:

### Table 3.3. Result of original then joined

<table>
<thead>
<tr>
<th>County Name</th>
<th>State Name</th>
<th>Area</th>
<th>1990 Census Population</th>
<th>2000 Census Population</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floyd</td>
<td>Kentucky</td>
<td>1,020</td>
<td>42,441</td>
<td>40,441</td>
</tr>
<tr>
<td>Loudon</td>
<td>Virginia</td>
<td>1,347</td>
<td>169,599</td>
<td>269,599</td>
</tr>
<tr>
<td>Floyd</td>
<td>Virginia</td>
<td>989</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In the final table, the extraneous data supplied in Example Data B (Adair, Iowa and Barren, Kentucky) which did not match entries in the existing table is discarded. Further, the lack of data about Floyd, Virginia resulted in empty columns.

Note that if only the County Name was used as a key, then both Floyd counties (the one in Virginia and the one in Kentucky) would have values set in all columns. However, the explicit use of a multiple key means that Cartographica will only consider a match when all elements match.

### 3.7. Acquiring GPS Data

Cartographica supports loading data directly into a mapset from a wide variety of GPS receivers. Imported data is represented as follows:

### Table 3.4. Imported Data

<table>
<thead>
<tr>
<th>Tracks</th>
<th>Loaded as lines with each line containing a full track and missing data being represented by discontinuous lines. Altitude is used as the Z coordinate. Time is used as the M coordinate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waypoints</td>
<td>Loaded as individual points, with each point containing as much data as is available; Z coordinates are set to altitude if available.</td>
</tr>
<tr>
<td>Routes</td>
<td>Loaded as continuous lines with each waypoint represented by a single point in the line. Altitude is loaded in the Z coordinate if available. M is ignored.</td>
</tr>
</tbody>
</table>

Because of ClueTrust’s long-standing efforts in Macintosh GPS connectivity (the free LoadMyTracks software has been given away by ClueTrust since 2006), Cartographica supports a large number of GPS devices for import. Please visit our support site for a detailed listing, but the classes of device and their manufacturers are listed in Table 3.5, “GPS Import Options” along with any special considerations for each type.

### Table 3.5. GPS Import Options

<table>
<thead>
<tr>
<th>GPS Type</th>
<th>Special Considerations</th>
<th>Import Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Garmin USB</td>
<td>Make sure that your Garmin USB GPS is plugged in and turned on before clicking Acquire.</td>
<td>Tracks, Waypoints, Routes</td>
</tr>
</tbody>
</table>
### Procedure 3.7. Acquire data directly from a GPS

1. Choose **File → Acquire GPS Data**.

   The Import GPS Data window appears.

<table>
<thead>
<tr>
<th>GPS Type</th>
<th>Special Considerations</th>
<th>Import Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Garmin Serial</td>
<td>Select the serial port that your Garmin GPS is connected to and click Acquire.</td>
<td>Tracks, Waypoints, Routes</td>
</tr>
<tr>
<td>Garmin Storage</td>
<td>Make sure that your Garmin Storage GPS is plugged in and turned on before clicking Acquire.</td>
<td>Tracks, Waypoints, Routes</td>
</tr>
<tr>
<td>GlobalSat DG-100</td>
<td>Select the serial port that your GlobalSat GPS is connected to and click Acquire.</td>
<td>Tracks</td>
</tr>
<tr>
<td>GlobalSat GH-615</td>
<td>Select the serial port that your GlobalSat GPS is connected to, activate Data Link to PC mode on the GPS and click Acquire.</td>
<td>Tracks, Waypoints</td>
</tr>
<tr>
<td>Lowrance</td>
<td>Make sure that your Lowrance GPS data card is plugged in and mounted on the Desktop before clicking Acquire.</td>
<td>Tracks, Waypoints, Routes</td>
</tr>
<tr>
<td>Magellan GPS</td>
<td>Make sure that your Magellan GPS is plugged in and turned on and that data transfer mode is selected.</td>
<td>Tracks, Waypoints, Routes</td>
</tr>
<tr>
<td>Magellan Serial</td>
<td>Select the serial port that your Magellan GPS is connected to before clicking Acquire.</td>
<td>Tracks, Waypoints, Routes</td>
</tr>
<tr>
<td>NMEA</td>
<td>Make sure that your SONY GPS is plugged in and turned on and that data transfer mode is selected.</td>
<td>Tracks</td>
</tr>
<tr>
<td>Timex</td>
<td>Make sure that your Timex Data Recorder is plugged in and turned on before clicking Acquire.</td>
<td>Tracks</td>
</tr>
<tr>
<td>TomTom</td>
<td>Make sure that your TomTom GPS is plugged in and turned on and that data transfer mode is selected.</td>
<td>Waypoints</td>
</tr>
</tbody>
</table>
2. Select the GPS type from the menu at the top of the window.

3. Choose one or more of Tracks, Waypoints, or Routes to include each of those in your import.

4. If you would like an external record of your GPS download, check Save GPX File and a GPX file will be created while the data is acquired.

5. Click Acquire. The data is imported into Cartographica in a new layer.

It is not uncommon for tracks to come from GPS devices as single features with multiple parts. Using Cartographica’s Split Feature, you can break these down into their constituent pieces. Similarly, if you have too many individual tracks, you can use the Merge Features and Merge Selected Layers… features to bring those together.

3.8. Acquiring Images from Web Map Servers (WMS)

There is an enormous amount of freely available or paid imagery available on the internet. Even after the popularity of the internet grew, exchange of imagery data online was difficult due to the wide variety of formats and protocols to access the data. This all changed with the creation of the Web Map Service (WMS) protocol as part of the work of the Open Geospatial Consortium (OGC). WMS provides a standard mechanism for browsing and specifying imagery data available from servers online and declares certain standards for the transport and representation of that data. Cartographica makes use of WMS to provide access to this ready resource of data.

Procedure 3.8. Acquire data from a WMS Server


The Acquire WMS Data Window appears.
The server list (on the left) shows a several WMS servers from which you can retrieve data. Once you have selected a server in the list, the description box below the server list changes to give a description of the selected server as broadcast from the server. The Source list on the right will display the options available for the selected WMS Server.

2. Select the server in the left column

Cartographica will retrieve the current layer information from the server and present it on the right Layer column.

3. Select one or more layers on the right

The Layer list on the right shows layers that can be added to your maps from the Server. Data marked with a red (-) cannot be added (usually because it is a category) and data marked with a green (+) can be added. When one of these sources is selected, a description appears in the box below the Source list.

In some cases, multiple layers can be added in the same request. If there is a limitation on the number of simultaneous layers that may be chosen, it will be displayed in the lower left.

4. Select the Coverage Area to determine how much information is downloaded from the server. The default Visible map bounds is generally suitable as it adds a margin around the current map's extent.

Figure 3.6. Acquire WMS Data Window

- Server list (left)
- Layer list (right)
- Coverage area options
- Download as Static Imagery

The server list (on the left) shows a several WMS servers from which you can retrieve data. Once you have selected a server in the list, the description box below the server list changes to give a description of the selected server as broadcast from the server. The Source list on the right will display the options available for the selected WMS Server.
**Selected layers** will limit the bounds of the imagery to the extent of the selected layers, and **Map bounds** will limit the bounds of the imagery to the extent of the current map, without any margin.

5. If want to download a copy to disk (as opposed to always fetching data from the server), check **Download as Static Imagery**
   
   Checking this box will download a single map to your hard drive. The quality of the imagery when you zoom will be decreased, but you will be able to work on the map even when you aren’t connected to the server, and your imagery will never change.

6. Click **Retrieve** to add the data to your map.

**Procedure 3.9. Add New WMS Server**

When you have the WMS Server sheet visible, you can add more servers to the source list on the left

1. Click the Add (+) button at the bottom of the left column to start adding a new server
   
   The Add new WMS Server window appears.

   ![Add new WMS Server window](image)

   **Figure 3.7. Add Map Server sheet**

   2. Enter the name of the server and the URL and click **Add**. The Server will appear in the source list on the left.

**Procedure 3.10. Removing a WMS Server**

When you have the WMS Server sheet visible, you can remove servers from the source list on the left

1. Select the name of the server from the source list on the left
2. Click **Remove (-)** beneath the source list

**Procedure 3.11. Editing a WMS Server**

When you have the WMS Server sheet visible, you can edit servers from the source list on the left

1. Select the name of the server from the source list on the left
2. Click **Edit**… beneath the source list
3. Change the name of the server and/or the URL and click **OK**
Chapter 4. Exploring Data

Cartographica is first and foremost a tool for exploration of data. This chapter describes many of the tools available for visualizing the data that you have. In concert with the analysis and presentation features, these tools provide a robust starting point for understanding the information within your data.

4.1. Zooming In and Out of Maps

There are several ways to zoom in and out of a map:

- Use the scroll wheel on the mouse while holding down the Option key on the keyboard
- Use the Zoom Dial on the right side of the Map Windows
- Use the Zoom To menu items in View to jump to particular zoom levels
- Use the zoom tool to zoom to points or areas using the mouse pointer
- Use the Previous and Next Extent items in View move to the previous or next zoom locations
Figure 4.1. Zoom Dial

Click and hold the zoom dial and move it up to zoom in and down to zoom out.

You can also zoom by clicking your mouse when you are using the Zoom tool. The Zoom tool also has a toolbar icon looks like this:

![Zoom Icon]

When the Zoom tool is selected, the cursor becomes a small little magnifying glass. Click anywhere in the map to zoom in and center the map on that point. To zoom back out, click while holding the Option key on your keyboard.

You can also zoom by selecting an area with the mouse (like drawing a box around it) when you have the Zoom Tool toolbar icon selected. You will zoom in to the borders of the box you just drew.

To go to the last Zoom use the Previous Extent/Next Extent menu options available in the View menu. Essentially, these options are undo/redo for zooming.
4.2. Selecting Data and Using the Identify Tool

The Identify tool allows you to draw around an area of features on the map or click one feature directly and make the data about that feature appear in the data window. The Identify tool toolbar icon looks like this:

Use the Identify tool to identify any feature in the currently selected layer. When you select the feature by either clicking on it, or surrounding it with a rectangle that you can draw (also good for selecting multiple features) the chosen items are highlighted in the data window.

For additional information display, Choose Window ➔ Selection Info to display the Selection Info window, which displays a scrolling list of information about each selected item. This is particularly useful if you have a lot of items selected which aren't next to each other in the data view, or if you have closed the data view to maximize map area.

FIGURE OF SELECTION INFO WINDOW

4.3. Using the Pan Tool to Move a Map

You can use the Pan tool to grab and move the map to change the view. The Pan tool toolbar icon looks like this:

Once you have selected the Pan tool toolbar icon, the cursor becomes a small hand with which you can move the map within the map window. Click the mouse at any point and then drag to move the map.

4.4. Data Tooltips

Data Tooltips show you summary information about selected features. By holding down the Option key while moving over any item in the selected layer, a small window will appear with information about the item you have moved over. The information that appears is defined in the Layer Info window.

Further, if you prefer to have Data Tool Tips available at all times without having to hold the option key, you can toggle them by choosing Map ➔ Show Data Tooltips

Procedure 4.1. Specifying Data Tooltip information

1. Choose Windows ➔ Layer Info to bring up the Layer Info Window.
2. Select the **Fields** tab to show the information about the columns

3. Check the **Popup** box on the line corresponding to the desired field.

The summary data is also used as the description information that is exported when using the KML exporter.

### 4.5. Measuring Distance and Area

You can measure distances and areas using the **Measure** tool. The **Measure** tool toolbar icon looks like this:

Once you have selected the **Measure** tool toolbar icon, you can use the mouse to measure distances and areas. Any measurements you make appear in the Scale box, which appears when you begin your first measurement.
In the Scale box:

- **X** and **Y** show the location (in map coordinates) of the mouse click (or just of the location of the cursor if you are not holding down the button).

- **X2** and **Y2** show the location (in map coordinates) of the cursor if you are holding down the mouse button.

- **ΔX** and **ΔY** show the coordinate differences between **X** and **X2**, and **Y** and **Y2** respectively (also in coordinate units).

- **Distance** is the distance of a straight line from **X,Y** to **X2,Y2** in linear coordinates.

- **Area** is the area of a rectangle bounded by "**X","Y" and "**X2","Y2" in linear coordinates. Essentially the line you create is making the diagonal for a rectangle that is bound by those points.

  "ΔX" and "ΔY" are in linear or angular coordinates depending upon the coordinate system of the map. However, distance and area are always in linear coordinates, using the great-circle method when the coordinate system of the map is natively angular.

- **Bearing** is the bearing (relative to the X axis of the data) from **X,Y** to **X2,Y2**.

To change the units for the measurements, select one of the gear drop down menus in the measurement window and choose the units. Units can be controlled and the scale itself may be restricted to a fixed size (in units). When using fixed unit size, the units will be adjusted to the next larger unit if the value could not be displayed in the available space.
To use the tool to measure distance:

To measure a line or distance between two points, select the **Measure** tool toolbar icon. Click on the first point from where you want to measure, hold the mouse button and drag the cursor to the second point. The distance between those points will be displayed in the Measurement window.

To measure area, select the **Measure** icon, place the cursor over one boundary corner of the area you want to know and then click and hold the mouse button down until you drag the cursor to the other boundary corner of the rectangle you want to measure. The area of the rectangle appears in the Measurement window.

**4.6. Using the Data View**

Most GIS data has geospatial information in the form of features (points, lines, and polygons) and non-geospatial data, which may consist of just about anything you can imagine: place names, number of crimes in an area, type of pavement on road. This data is sometimes displayed on the map as labels, represented by colors, or visualized in other ways.

The data view is located at the bottom of the main Cartographica window. This is a standard Mac OS X table, and works the same as other tables on the platform.
The layer that is shown in the data view is the layer that is currently selected in the layer stack. If you are looking at the screen and wondering why the data you're looking for is not what you expect, check the layer stack and make sure the layer you are interested in is selected. If you have more than one layer selected in the layer stack, no data will be shown in the data view.

Further, the selection in the data view is synchronized with the selection in the map view, which means that if you select a feature in the map view, the data view will scroll such that the information about that feature is visible. Similarly, if you click on a row (or rows) in the data view, the corresponding map view features will be selected.

**Procedure 4.2. Sorting the Data View**

1. Click on the heading for the column on which you would sort the view
   
   The table will sort to your specifications and an arrow will be displayed at the right side of the header to indicate the sort order.

2. To sort in the opposite order on the same column, just click again in the column heading.

**Procedure 4.3. Re-ordering columns in the Data View**

- Click on the column heading and drag it to the new location

  The column will move from its old location to the new location

**Procedure 4.4. Editing data in the Data View**

Editing most of this data is very straightforward as it is done directly in the data table below the main Map in the Map Window. Once you have a layer selected, click on the individual cell of data and start typing.

1. Select a single layer in the layer stack

   Cartographica will display the data for this layer in the data view

2. Select a feature:

   - Click on a feature in the map
   - Click on a row in the table

   The feature will be selected in both the map and the Data View.
3. Click in the column to change

The blue focus box will show up around the table cell indicating that you may now enter your data

Columns which have been locked or which contain Column Formulas cannot be edited and will not enable when clicked.

4. Press the enter key to finish editing

4.7. Adding, Removing, and Renaming Columns

Columns may be added to and removed from any layer. There are some restrictions on exactly how this is done.

Table 4.1. Column Change Restrictions

<table>
<thead>
<tr>
<th>Layer Type</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>All By Reference Layers</td>
<td>Columns added to By Reference layers will require either internal saving or updating the original file to keep their data. This only happens when you save the Map Set, so if you are doing this temporarily there is no harm. The only exception to this are Formula Columns, which are only stored in the Map Set and can continue to use the By Reference data.</td>
</tr>
<tr>
<td>WFS Layers</td>
<td>Columns added to WFS Layers will not create new columns on the server. Any data that is added to these layers will be lost when the Map Set is saved and re-opened. As with By Reference layers, Formula Columns will have their data recomputed on load and thus will not be lost when saving a Map Set.</td>
</tr>
<tr>
<td>Live Maps</td>
<td>There are no features and thus no columns for Live Maps.</td>
</tr>
</tbody>
</table>

Columns of any data type may be added in Cartographica. By default, the Add Column command from the Layer menu will add a String column, which can represent textual or numeric data.

Procedure 4.5. Adding Columns to a Layer

1. Select the layer in the Layer Stack
2. Choose Windows → Show Layer Info to bring up the Layer Info window
3. Click the Fields tab to show the list of columns
4. 
   - Click +
   - Choose Layer → Add Column

   A new column will be added to the column list and brought into view
5. Optionally change the type of the column by selecting from the corresponding Type cell
6. Optionally change the size of the column by clicking in the corresponding Length cell

**Procedure 4.6. Removing Columns from a Layer**

1. Select the layer in the Layer Stack
2. Choose Windows → Show Layer Info to bring up the Layer Info window
3. Click the Fields tab to show the list of columns
4. Select the column to remove
5. • Click -
   • Choose Layer → Remove Column

The selected column will be removed from the column list

**Procedure 4.7. Renaming Columns in a Layer**

1. Select the layer in the Layer Stack
2. Choose Windows → Show Layer Info to bring up the Layer Info window
3. Click the Fields tab to show the list of columns
4. Select the column to rename
5. Click in the corresponding Name cell and type the new name

The selected column will be renamed

**4.8. Using the Selection Window**

The Selection Window shows information about the features you select in the data window. To access the Selection window, go to Window → Show Selection Info.
Figure 4.6. Selection Window

The Selection Window is best used for looking at specific data when you have multiple items selected in the map or data view.

The left-hand side controls what information is available in the right-hand side. By double-clicking on the left hand side, the Data View and the map view window will change to show only those items selected in the column on the left-hand side.

4.9. Using the Point Data Window

The Point Data window is used for looking at the detailed geometric data of a feature. To open the Point Data window, choose Window → Show Point Data.

All data in the Point Data window is expressed in the original coordinates. Modifying geometric points will cause those points to be reprojected onto the current map's coordinate system.

Generally, it is easier to edit if Maps and Layers are (at least temporarily) set to the same value.
Figure 4.7. Point Data Window

Use the left side of the window (Part) to select the part within the feature (many features have only one part, but others may have many). The right side of the window (Point) shows the list of points in the selected Part. In the case of a Line, a part describes disjoint line segments. In the case of a Polygon, the parts describe islands or holes in the Polygon.

4.10. Additional Layer Info

From the Layer Info Window click the Info Tab. The Info tab appears.
Figure 4.8. Layer Info Window - Info Tab

The Info tab displays some additional information about the Layer.

**Representing**
This pop-up menu describes the information that this layer represents. This serves only as a guide for the software and for users.

**Feature Name**
This pop-up determines which column in the data for this layer is used as the feature name during display. This affects certain output formats (such as KML) which have use for a name field and is displayed in Data Tool Tips.

**Geometry**
Describes the type of features represented in this layer. Possible values are: Point, Polyline, Polygon, Image.

**Objects**
Provides a count of the number of features in this layer.

**Points**
Provides a count of the number of points in all features in this layer. This is a rudimentary measurement of complexity.

**Bounding Box**
Shows the upper left and lower right coordinates of the bounding box in map coordinates.

**Base Bounding Box**
Shows the upper left and lower right coordinates of the bounding box in layer coordinates.
Chapter 5. Working With Layers

5.1. Using the Layer Stack

The Layer Stack appears on the left side of the Cartographica Window. This view shows all of the different layers of data that appear in the map.

![Layer Stack](image)

**Figure 5.1. The Layer Stack**

The Layer Stack defines what appears in the Map View and Data View.

You can drag items to re-order them in the layer stack. Top is “on top” if you were to think of it as a layer cake or a set of papers layered on top of each other. Often, if you are using a raster layer, you’ll drag that to the bottom so that all the vector content sits “above” it.

You can also drop a layer on another layer to copy styles from the dropped layer to the dropped-on layer. Although it might seem strange, you can also drop a layer on another layer of a different type. This allows for an easy way to copy the color schemes.

**Procedure 5.1. Showing and Hiding layers**

You can choose which layers are shown on the map by

- Toggling the checkbox next to the layer name in the layer stack
- Choose **Layer → Hide Layer** or **Layer → Show Layer**

When you do hide a layer the features contained in this layer are no longer seen on the Map.
5.2. Using the Layer Info Window

The Layer Info window shows the data features of the layer that is selected. It is used to add/remove columns, change data types, and modify column names. To access the Layer Info window, choose Window → Show layer Info. The Layer Info window appears showing the Fields tab.

![Figure 5.2. Layer Info Window - Fields Tab](image)

5.3. Filtering on Layers Using the Filter Box

You can use the Filter Box from the main window to filter map data within a layer and to create new data layers with the results. The Filter Box appears in the top right of the main Cartographica window.

![Figure 5.3. Filter Box](image)

Enter the data you want to filter into the search box. As you type, the results are narrowed and are displayed (filtered) in the data window. This filter is extremely fast, even for large datasets and is the preferred method for finding an item in the data window. Use the Filter Box with Layer/Create Layer from Selection from the Layer menu to split off data that is interesting for further analysis. The filter operates on the layer currently selected in layer stack. The filter works by filtering the data in the selected layer as shown in both the data and map views. You can also use extensions such as commas to further filter results.
And/or and multiple-field data filtering is now possible and easy with this new system. The existing filter box works as a short-cut, translating queries into the new system, which can then be edited.

As you type into the filter box, you will see a drop-down area at the top of the Map View that contains a much more flexible filtering system.

![Advanced Filter Box](image)

**Figure 5.4. Advanced Filter Box**

You can select which filter or all filters to use by selecting either *Any*, *All* or *None of the following are true*.

The first selection drop down menu (shown as `info.Capital` in the screen above) is a menu to select which column in the data window you want to search.

Then you can select if you want the filter to be *is the less than*, *is greater than*, or *is*, or *contains* the filter phrase.

The text box contains the text you enter that you want to filter on.

You can click the + or - button to add or remove additional filters.

Click the Done button to dismiss the additional Filter boxes and restore the maps and data views to all features in the selected layers.

You can also filter using variables from the same or multiple fields. This is useful for creating new layers.

### 5.4. Adding and Removing Layers

Although most layers are added to Cartographica map sets by importing them from existing files or network services, it is quite reasonable to create a layer yourself. Most frequently the goal of adding a layer is manually create some new features (such as drawing an area over an existing map).

**Procedure 5.2. Adding New Layers**

1. Choose Layer → New Layer
   - Click on the Add(+) button under the Layer Stack
     - The new layer is added with no data and a default name
2. Click on the name in the Layer stack to select the text and then replace with your new name

**Procedure 5.3. Removing Layers**

1. Select the layer you wish to remove in the Layer Stack
2. Click on the Remove(-) button under the Layer Stack
• Choose Layer → Delete Layer

The selected layer is removed

5.5. Adding a New Layer Based on a Data Selection

If you want to create a new layer from a selection of data in your map, select the data you want to add to a new layer in the Data window. Now, Layer → Create Layer from Selection.

You can also select a data set using the filter bar to create a filtered list of data to create a new layer from.

This creates a new layer that will appear in the Layer stack from the selected features in the current layer, copying the styles and all data attributes.

5.6. Merging Layers

Cartographica can merge layers with similar data into a single layer, creating a new layer with the contents of all the selected layers, and removing the original layers.

This is commonly used to put like data together in a single layer for easy manipulation.

Consolidating layers will remove all of the selected layers from the map and replace them with a single layer that has all of the features of the selected layers.

• Layers must contain the same kinds of features (points, lines, or polygons).

• Layers with different dimensionality (2D, 3D, or 4D) will be upgraded to the highest dimensionality of the set.

• Optionally, you can choose to consolidate data fields for layers containing columns of the same name by clicking the Consolidate data fields with the same name checkbox. Columns with different names will be appended and the data for the other features will be left blank.

1. In the Layer Stack, select the multiple layers you want to merge, by command-clicking the mouse on each layer.

2. Layer → Merge Selected Layers.

The Merge Selected Layers dialog appears.
3. If you would like to add a column to each entry in the new layer stating which layer the entry originated from, click the Add original layer name in From Layer field checkbox.

4. Choose which Layer the styles come from using Inherit styles from drop down box.

5. Now click Consolidate.

5.7. Masking Data for Analysis Layers

When using an analysis layer (for now only created by the Kernel Density Map), often the analysis layer has a significant amount of data falling "outside" of the area of interest. To help remedy this, Cartographica can constrain the bounds of the analysis layer to the area of a polygon layer.

Below are examples of an analysis layer, the mask to be applied, and the resultant masked analysis layer. In this case, we use a Kernel Density Map and have a satellite map in the background as illustration.

Figure 5.6. Analysis Layer without Mask
Procedure 5.4. Masking an analysis layer

In order to mask an analysis layer, you need to have a polygon layer that specifies the area you want included in the analysis. You can either use an existing polygon layer, or create one manually or using tools such as Cartographica’s Tools → Make Convex Hull

1. Select the analysis layer in the layer stack by clicking on it
2. Select the polygon layer in the layer stack by holding the option key while clicking on it
3. Choose Layer → Set Mask Layer

After a few seconds, the analysis layer will be masked by the polygon layer you selected.

The mask layer will work even if the mask layer is hidden, so you can add a layer to act as the mask, assign it to the analysis layer, and then hide the mask layer without losing the mask effect, but without having whatever data is in that layer displayed.

Procedure 5.5. Removing an analysis layer mask

1. Select the analysis layer in the layer stack by clicking on it
2. Choose Layer → Clear Mask Layer

5.8. Setting Layer Projection

In the event that a layer of data is imported without any projection information, Set Layer Projection can change the projection without modifying the data.
It is common for data that comes in csv form to be delivered in a State Plane Coordinate System instead of Latitude/Longitude (which will be automatically selected in most cases). In the case that the projection information is not there, use the following process to set the layer projection.

1. **Layer → Set Layer Projection** to set the layer’s projection information.

   The Set Projection Layer dialog appears.

   ![Set Projection Layer Window](image)

   **Figure 5.9. Set Projection Layer Window**

   Setting the projection here will change the projection for this particular layer, but it will not change the shape data. Changes will be saved in the map file and possibly in an associated PRJ file.

2. From the left side of the dialog, choose the map projection that best suits your needs.

   The Description box on the right will change depending which projection is selected. You can also click the Specifications tab to see additional details about the selected projection.

   Below this informational area there is a small preview area that gives a general orientation for the features of your map once the selected projection has been confirmed.

   Here you should use the filter box to search for a projection.

   The feature projection shape is previewed on the right side of the window so you can get an idea of what the selected projection will look like.

3. Once you have the selected the projection that best suits your needs and most accurately represents the data you are attempting to display, click **Set**.
5.8.1. Reprojecting Layers

Cartographica allows users to change the geographic projection of data to several predefined datums. The limited applications include preparing data for export in another CRS.

For example, if you need a shape file in WGS84, but you have data in State Plane, you can use Reproject Data to change the data from the State Plane to WGS84 and then use the Export Layer command to export it.

This is seldom the case, so most often, you can use Map → Project Map to set the map projection or Layer → Set Layer Projection to change how the features in a particular Layer are interpreted.

To permanently change the map projection:

1. Layer → Reproject Layer.

   The Reproject Layer dialog appears.

   ![Figure 5.10. Reproject Layer dialog](image)

   **Figure 5.10. Reproject Layer dialog**

   Changing the projection here will permanently modify the shape data to correspond to the selected projection. If you reconvert it back to the original, it is likely that a loss of accuracy will occur. If you're not certain you want to do this, set the projection.

2. From the left side of the dialog, choose the map projection that best suits your needs.

   The Description box on the right will change depending which projection is selected. You can also click the Specifications tab to see additional details about the selected projection.
Below this informational area there is a small preview area that gives a general orientation for the features of your map once the selected projection has been confirmed.

3. Once you have selected the projection that best suits your needs and most accurately represents the data you are attempting to display, click Set.

5.9. Referenced Data

Cartographica tries to be intelligent about referencing external data in order to maximize efficiency and convenience. In many cases, Cartographica can make an external reference to a file instead of making it part of the Mapset. This data is referred to as being Externally Referenced.

When a layer is Externally Referenced, it has a by reference icon in the layer stack on the right side. Also, when that layer is selected, the Layer menu’s Include Layer Data in Mapset item is unchecked.

Often, storing boilerplate data and large imagery in external files is desired to save space and to make updating that data easy. Imagine having a set of 10 maps that all need road information, but your road information changes on a monthly basis. If your road polygons are kept in an external file, you need only update the external file, load your mapset and the information is up-to-date.

The main reason to use this is if you need to "Freeze" the data for a particular layer so that you don’t accidentally change it.

Procedure 5.6. Bringing External data into the Mapset

1. Select the desired layer from the Layer Stack

2. Choose Layer → Include Layer Data in Mapset to bring the data into the Mapset. The next time you save, a copy of the data will be made inside of this Mapset.

Once a data set is brought into the Mapset, the only way to make it external again is to delete the layer with the internal copy and re-import the data.

Occasionally, you may need to create a copy of a Cartographica Mapset for distribution to other parties or to archive the complete state of a map and all its constituent parts. In this case, often it is necessary to put all of the data into the Mapset file before sending it because the recipient may not have the original files. Since permanently changing this might not be desired, you can save a copy of your Mapset file that has had all of its layer data brought internal, or "flattened".

Procedure 5.7. Flattening a Mapset

1. Choose File → Save As to begin the saving process

2. Check Flatten Map When Saving to flatten the file

3. Now choose a file name and click Save
Chapter 6. Working With Styles

Styles determine how a map looks when viewed, printed, embedded in a map layout, or exported to any style-conscious format (such as Adobe Illustrator or KML).

Cartographica has a sophisticated style system which provides significant control over how data is shown on the screen and in printed output.

Styles are assigned and manipulated for each layer individually.

Procedure 6.1. Opening the Style Editor

To bring up the Style Editor for any layer, use one of the following techniques:

1. Select the desired layer in the Layer Stack
2. Double-click on the layer to open the Style Editor
   - Click on the Styles… button at the bottom of the Layer Stack to open the Style Editor
   - Choose Layer → Show Layer Styles

At this point, you should have an appropriate Style Editor Window visible.

![Layer Styles Window (Vector)](image)

Figure 6.1. Layer Styles Window (Vector)
6.1. Styling Vector Layers

Styles in Cartographica are a very powerful mechanism for changing the presentation of your map. By using the values of data in the features, Cartographica can create thematic maps without requiring manual intervention in every step of the process.

When Cartographica prepares to draw a particular feature, it first evaluates the style, as defined in the layer’s Style Window, to determine if the feature qualifies for a particular style variation, or if it is to be drawn with the Default Style. For layers where you desire all features in the layer to look the same, use only the default style and all features will be drawn the same.

Vector styles share many traits, although each different type of feature (lines, polygons, and points) have some unique attributes and slight variations in how the standard attributes are applied.

For all style manipulation, work begins in the Style Window.

![Style Window (displaying a complex point style)](image)

**Figure 6.2. Style Window (displaying a complex point style)**

The style window is divided into three primary areas:

- The upper left portion of the window contains the Style List, which is used to discriminate between styles in a style set. All layer styles can either be comprised of a single style (in this case, referred to as the Default Style) or multiple styles. This will be covered later in Section 6.1.5, “Complex Styles”.

---

49
The right side of the window is the Appearance pane and it determines how each feature in a particular style looks. This includes the label, marker, lines, colors, and naming.

The lower left portion of the window is a Preview of the style you are currently working on. In the case of multi-style style sets, the selection in the Style List determines which style is shown in the Preview.

Since many of the elements of the Appearance pane are common to every feature type, we will examine what each element represents and how it can be used, going from the top to the bottom.

- **Name** is used in the Map Legend and other areas of the software to represent this particular style in a style set. In the case of the Default Style, it is fixed by Cartographica, otherwise, you can feel free to name it anything appropriate for your needs.

- The **Fill** color well is used to select the Fill color for the features. The particulars are slightly different for each feature type, but generally Fill is the color that goes in the "center" of the feature. For example, in a line, it is the center of the line (with the stroke forming a border around the fill color. For a polygon, the fill is inside the entire encompassed area. For a point, it is highly dependent on the symbol type.

- The **Stroke** color well is used to select the Stroke color for features and determine if the stroke will be used in the feature. As with the Fill field, the particulars are slightly different for each feature type. Regardless of how it is represented on the screen, the stroke color is only visible when the box next to it is checked.

- The **Size** field (named **Point Size** for points, and **Line Width** for both polygon and line layers. The slider and the text box are both used to control the size. Nearly any size is allowed, but not all of them will be very pleasing to the eye.

- **Symbol, Picture, and Picture Path** are only available when editing Point features, and so they will be covered in Section 6.1.1, "Point Styles”.

- **Item Label** and **Insert Field** menus are used to determine what text should be placed next to the point, along the line, or inside the area. You can add text to the label by typing into the box, and references to fields can be added by placing the cursor where you want the field and then using the **Insert Field** pop-up menu to select the field you want added. A field marker (with the name of the field inside of a colored cell) will be placed at the cursor location. This is covered in depth in Section 6.1.4, "Labeling Features”

### 6.1.1. Point Styles

Of all of the feature layers, point layers offer the most variation in form. The Point Size slider and box control the total size of the point item. Due to variations in particular symbol drawing techniques and different visual weights (which affect apparent size), it is often the case that symbols with the same size are similar, but not identical in size or area. This is to be expected. We have tried to keep the sizes consistent for all symbols created directly inside of Cartographica, but you may need to balance sizes a bit, especially when using custom picture- or font-based symbols or when using symbols of greatly differing weights.

For most Point symbols, the **Stroke** checkbox and color well determine if the outline of the symbol is visible and the color of the symbol outline. Not surprisingly, the **Fill** color well determines the color which fills in the symbol. For some symbols, there is no "fill" area, and therefore the symbol's fill color does not matter and the stroke must be present for the symbol to draw. Examples of these in the built-in symbols are the cross and plus.

Although Cartographica may not ship with the variety of symbols of some other programs, the ability to import high-resolution symbols from a variety of places makes up for many missing symbols. To change a symbol, the **Symbol Well** is used as the dropping point for one of a variety of sources:
• The Symbols Browser window, which is the built-in repository for scalable symbols (pictured in Figure 6.3, "Symbol Browser Window"), contains a number of common symbols for use on maps which are simple, but highly scalable.

• Images from a variety of sources. Basically any image that you can get onto your Macintosh is usable as a symbol in Cartographica. This can be a graphic from a web page, something designed in illustrator, or a licensed piece of clip-art. When an image symbol is used, Cartographica pays attention to the alpha channel for transparency, meaning that transparent-capable formats such as PNG are more desirable than JPEGs, as an example.

• The Macintosh Character Viewer. The Character Viewer is a standard part of the OS, which is made visible on the screen by checking the Show Keyboard & Character Viewer in menu bar option in the Keyboard preferences panel in System Preferences. Once this box is checked, you can bring up the window by choosing Show Character Viewer from the menu bar. Any character from the palette can be made into a Cartographica symbol just by dragging it into the Symbol Well. Among the available symbols in many standard fonts are: airplane, a variety of stars, and many more. Plus, cartographic symbol fonts are also available from a variety of commercial and non-commercial providers.

• Stylized text from any window. Although single-characters are often enough and our labeling system provides ample opportunity to provide static and variable text labeling, text from any window can also be used as a "symbol" for a point.

Besides symbols, Cartographica can also represent points with a picture stored on disk by using the Picture check box and field selector and optionally the Picture Path to specify the location of the referenced pictures. When using a picture to represent the points on the map, the Picture box must be selected and a field must be chosen in the pop-up menu. The picture field designates which column contains the file name of the referenced file, which can be a full or partial path name. A partial path name is resolved first by looking at the Picture Path and then by using the directory the layer (or map set for an internally-stored layer) is saved in as the default. When using a picture symbol, the Image Viewer will come up whenever a represented point is selected, showing a larger version of the picture (or a playable version of the movie, if the referenced data is a movie file).

![Figure 6.3. Symbol Browser Window](image)

Labels may also be added to point features, see Section 6.1.4, “Labeling Features” for further information.

**Procedure 6.2. Setting the Symbol for a Point layer**

1. Open the Style Editor for the desired layer

2. Click once in the Symbol well in order to bring up the Symbol Browser Window.
3. Choose a symbol from the Symbol Browser Window and drag it to the Symbol well

4. Adjust Point Size, Stroke, and Fill as desired

Procedure 6.3. Using a Font Character as a Symbol for a Point Layer

1. Open the Style Editor for the desired layer

2. Bring up a window containing the font character. Commonly this is done with the Show Character Viewer item from the menu bar (if you can't find it, you may need to turn it on in the Keyboard System Preferences

3. Choose a symbol from the character viewer or other window and drag it to the Symbol well

4. Adjust Point Size, Stroke, and Fill as desired

Procedure 6.4. Using an Image File as a Symbol for a Point Layer

1. Open the Style Editor for the desired layer

2. Bring up a Finder window containing the symbol file

   The file should be one of the standard image types understood by the MacOS X, such as PDF, Adobe Illustrator, GIF, JPEG, PNG, etc.

   ![](image)

3. Drag the file to the Symbol well

4. Adjust Point Size, Stroke, and Fill as desired

   The effect of the Stroke and Fill on image symbols can be a bit strange. Generally, you will want to use the Stroke box and color only if you want to completely fill the symbol with the stroke color.

![](image)

Procedure 6.5. Using Pictures as a symbol

Before using pictures as a symbol, you must make sure that you have the picture files in a format that MacOS X understands, such as JPEG, GIF, or PNG. You must also know where those files are in relation to the Picture Path or the layer data.

These instructions assume that you already know where the pictures are and have a column that contains the partial or full path names to the picture files.

1. Open the Style Editor for the desired layer

2. Select the name of the column with the paths by using the Picture pop-up

3. If your photos are referred to by partial path names, you may need to select the Picture Path by using the pop-up menu

4. If you would like the pictures to show up in the map as the Point symbol, make sure the Picture box is checked
To change the size of the displayed picture on the map, use the **Point Size** slider or box.

### 6.1.2. Line Styles

Line styles can be used to change the coloring, size and labeling of line features on the map. In comparison to Point styles, the Line styles are much simpler, having really only 4 parameters: **Fill**, **Stroke**, **Line Width**, and **Item Label**.

When a line is drawn, Cartographica uses the **Fill** color to form the middle of the line (and thus the entire line on an unstroked line). Thus, a single-color line has no stroke.

The **Stroke** box and color well are used to determine whether an outline stroke is drawn and what color it will be when it is displayed. A traditional highway would be a stroked line, whereas a path or smaller road would typically be unstroked.

The Line Width determines the width of the line, and in the case of a stroked line, the width of the stroke as well. The two are proportionate, with the line width determining the width of the Fill area, with half-again as much width used for strokes on either side if Stroke is selected.

### 6.1.3. Polygon Styles

Polygon styles can be used to change the coloring, size and labeling of polygon features on the map. Polygon styles, like Line styles are simple, having really only 4 parameters: **Fill**, **Stroke**, **Line Width**, and **Item Label**.

When a polygon is drawn, Cartographica uses the **Fill** color to form the area of the polygon. The **Stroke** box and color well are used to determine whether an outline stroke is drawn and what color it will be when it is displayed. A traditional provincial border would be a stroked polygon.

The Line Width determines the width of the stroke around the polygon in the case of a stroked polygon.

### 6.1.4. Labeling Features

All styles can be labeled, providing a way to indicate the name or other attributes of a feature on the map.

Labels are among the most complex options in Cartographica due especially to the need to avoid clutter and collision when items are placed near each other. Although the particular algorithm cannot be described in detail and is subject to some amount of change, here are some important points to understand about how Cartographica handles labels:

- All labels are drawn after all features are drawn and therefore labels show up "on top" of all features, including those features above the features that are being labeled. This prevents problems such as the label for a State (usually a polygon layer) being occluded by the point and label for a city in that state (usually a point layer positioned above the polygon layer so that the features are visible).

- Labels are evaluated in layer order, which is to say that the labels of layers at the bottom of the layer stack have a higher priority than those at the top of the stack.

- Within a layer, labels are evaluated in draw order, which is really not deterministic, and therefore there is not a good way to tell which labels in a layer will be drawn a priori.
• The best way to control labels is to only turn them on for items that are important for display purposes. This can be achieved by using a Complex Style (see Section 6.1.5, "Complex Styles") to separate the labeled and unlabeled items.

• When necessary, very complex labels can be made by using a Calculated Column (see Chapter 13, Column Formulas) to create the contents of the field and referencing that calculated field in the label.

• Labels can have multiple lines, which are added by inserting a return in the Item Label box.

Labels are controlled by the content of the Item Label box, shown in close-up in Figure 6.4, "Label field". Labels can contain text and fields and can be styles using one or more fonts and sizes. The example shown here is a simple label containing introductory text "Zip:" and the contents of the ZIP_CODE field. In the Item Label box, the contents of a field are represented by a Field Marker, which is the name of the field surrounded by a colored oval.

Field Markers may be moved around through drag and drop and may be copied, pasted, and deleted.

![Item Label: Zip: ZIP_CODE](image)

Figure 6.4. Label field

**Procedure 6.6. Add a label to a style**

1. Click in the Item Label box to move the text cursor there
2. Type the desired text in the box
3. Type text into the box to create an unchanging text label
   - Choose the desired field from the Insert Field pop-up menu to insert the field marker into the label.

**6.1.5. Complex Styles**

So far, we have been describing simple styles, which apply identically to every feature in a layer. However, it is often the case that some features in a layer deserve special attention. Examples of this include a layer that contains cities, some of which are state or country capitals, or a layer of roads that contains both local roads and large highways. In each of these cases, some of the features in the layer are singled out for special attention.

Complex Styles are also used when attempting to show quantitative or qualitative attribute information graphically. For example, a polygon layer representing states could be colored differently based on population; similarly, the size of a city symbol in a point layer could vary based on population.

There are three primary controls for complex styles: the Based on: pop-up menu, which is used to determine which field is used to discriminate between the styles; the style list on the left side of the window above the Preview box, which displays the list of defined styles and provides for addition, deletion, etc.; and the Hide features that don't match check box, which determines whether the Default Style is used.
In complex styles, the **Based on** pop-up menu determines which column of data is to be used for discriminating between the styles. Once the column is selected, use the table on the left of the window to determine the breaks for each style variant.

When using a string column to discriminate, you must use the **Value** column, which indicates an exact match between the value in the column and the one you define in the style here. When using a numeric column to discriminate, you may use either the **Value** column or the **From** and **To** columns. For the **Value** column, the data must still match exactly. When using the **From** and **To** columns, the value must be within the range specified. The Distribute button may be used to help create natural ranges based on a linear distribution over the range of the data in the selected layer.

Under **Based on** are 3 pieces of data that appear when a column name is selected. These are the field type (string, number, date), and the minimum and maximum values.

The table in the left of the window lists the values or ranges for each style in the style set. To change the appearance of the style, select it in the table at the left and then adjust the parameters on the right, using the techniques described previously for each feature type.

You may also select multiple styles at the same time, allowing simultaneous editing of items. This is useful, for example, when using different symbols, but wanting to change the size for each of them. In this case, select the desired styles and then change the size. The size will change, but the remainder of the appearance will remain unchanged.

Styles are added to the list by using the + and - buttons, or by Edit → **Duplicate** or Edit → **Duplicate and Increment**. The + button adds a new style by copying the default style. Each of the menu items provides a way to add an identical copy of the selected style to the list, with the **Duplicate and Increment** also increasing the **From** and **To** values.

When using quantitative information to discriminate between styles, it is often beneficial to have Carto-Graphica assign breaks between the styles. The gear menu provides access to these functions, as outlined below:

- **Distribute With Equal Intervals**: distributes the values of the **Based On** field across all of the styles in the style list. For example, if the values range from 0-100 and you have 4 styles currently in the list, those styles are changed to range from 0-24,25-49,50-74, and 75-100 respectively. No other changes are made to the styles and the number of styles are not changed.

- **Distribute With Natural Breaks (Jenks)**: distributes the values of the **Based On** field using the Jenks natural breaks distribution method. This method will calculate the natural breaks that occur in the data set, based on attempting to determine where clusters of values exist. No other changes are made to the styles and the number of styles are not changed.

- **Distribute With Equal Count**: distributes the values of the **Based On** field by making each range contain an equal number of features. This is done using an increasing value, so the ranges will always be contiguous. For example: 5-10,11-20,21-30, etc.

- **Distribute With Equal Area** (available only for polygon layers): distributes the values of the **Based On** field by making each range contain an equal area on the map, in the current CRS. This is done using an increasing value, so the ranges will always be contiguous.

- **Distribute With Quartile Distribution**: distributes the values of the **Based On** field into four (4) groups by making each range contain an equal number of features. This is done using an increasing value, so the ranges will always be contiguous. When applied to a style set, any existing styles will be used up to the fourth one, and all styles beyond the fourth will be removed.
• **Distribute With Quintile Distribution**: distributes the values of the **Based On** field into five (5) groups by making each range contain an equal number of features. This is done using an increasing value, so the ranges will always be contiguous. When applied to a style set, any existing styles will be used up to the fifth one, and all styles beyond the fifth will be removed.

• **Distribute Unique Values**: distributes the values of the **Based On** field into one group per value. This is mostly for use with string columns, although numeric columns with a small number of actual values can also be used. When applied to a style set, any existing styles will be used where possible, and all styles beyond those necessary will be removed.

All style information updates immediately, both in the preview window and in the map view, so the user should be able to drag the sliders and move around with the color picker until they have matched what they need.

**Procedure 6.7. Applying a palette of colors to a set of styles**

It is often desirable to use a set of common colors for particular maps. Cartographica provides an easy way to take a color palette and apply it to the fill or stroke color of each element in a style list in turn. The result is a series of different colors, one for each style.

1. Open the style window for the desired layer
2. Choose **Window → Show Color Palettes** to bring up the **Color Palette** window.
3. Choose a color palette and drag it to the style list, dropping it when the cursor changes to the add cursor.

   To change the stroke color instead of the fill color, hold down the **option** key on the keyboard when you drop the palette.

**Procedure 6.8. Temporarily disable all styles for a layer**

This method disconnects the discrimination logic, leaving every feature in the layer at default. No other parameters are changed, so it can be used safely to "flatten" the appearance of a layer without actually changing its style.

1. Open the style window for the desired layer
2. Change the **Based On** value to **None**

   None of the other settings for the style set will be changed by doing this, so you can change back to your previous style settings just by returning the **Based On** pop-up to its previous value.

**6.2. Styling Raster Layers**

For raster layers, the styling is much simpler than for vector layers. Since the raster layer often contains detailed color data, there is no real need for a complex system as with vectors.

For some raster layers, their content is a representation of data instead of imagery. In these cases, Cartographica can be used to visually color the raster layer based on the values of data in the layer.
For both of these cases, you can adjust the opacity of the layer so that it may be placed above another layer, mixing some of the contents of the underlying layer with the contents of the overlaid layer.

Although a number of color palettes are included with Cartographica, see Chapter 14, *Color Palettes* for more information about using and editing color palettes.

![Raster Layer Styles Window](image)

**Figure 6.5. Raster Layer Styles Window**

**Procedure 6.9. Adjusting a Raster Layer's opacity**

1. Select the layer in the layer stack
2. Choose **Layer → Show Layer Styles** to bring up the Raster Layer Style Window for this layer.
3. Drag the **Layer Opacity** slider to the desired opacity
   The layer on the Map will update as you do this
4. Close the Raster Layer Style Window

**Procedure 6.10. Changing a Raster Layer's palette**

1. Select the layer in the layer stack
2. Choose **Layer → Show Layer Styles** to bring up the Raster Layer Style Window for this layer.
3. Choose **Window → Show Color Palettes** to bring up the Color Palettes window.
4. Select a new palette from the list and drag it to the Palette well in the Raster Layer Style Window
   The layer color in the map should be updated immediately
5. Close the Raster Layer Style Window

If you are working with a true-color image (one with component RGB), the palette well will not be available.
6.2.1. Concentrating the palette representation

In some cases, the entire range of the data is not useful for visualization. This can happen, for example when a data set contains mostly data in a small range, but has a few outlier data points that are the result of errors in data gathering. It can also happen when the interesting range is a small fraction of the total range of the data. Cartographica can visualize a smaller (or, in fact, larger) range of data values without having to modify the underlying data by constraining the application of the palette to a different range of values than those in the sample set. All values above the range and below the range are clamped to the highest and lowest values respectively.

**Procedure 6.11. Constraining palette range**

1. Select the layer in the layer stack
2. Choose Layer → Show Layer Styles to bring up the Raster Layer Style Window for this layer.
3. Check Manual to enable using a manual range for the palette
4. Type new values into the Minimum and Maximum boxes to determine the specific range.
5. Close the Raster Layer Style Window

**Procedure 6.12. Setting automatic palette range**

1. Select the layer in the layer stack
2. Choose Layer → Show Layer Styles to bring up the Raster Layer Style Window for this layer.
3. Uncheck Manual to use the automatic range
4. Close the Raster Layer Style Window

6.3. Map Background Color

Cartographica can draw a background color behind all visible features in order to make the features stand out. Although this may be desirable for maps that are vector-based and have no styles, it can be distracting for choropleth maps.

You can change the background color for an individual map and also change it for all new maps going forward.

**Procedure 6.13. Changing the background color of a map**

1. Choose Edit → Show Colors to bring up the Color Picker
2. Select or create a color of your choosing
3. Drag the color sample from the Color Picker to the Map View
4. Close the Color Picker

**Procedure 6.14. Changing the default background color for new maps**

1. Choose Cartographica → Preferences… to bring up the Cartographica Preferences window
2. Click **Default Map Background Color** color well
   
   The Color Picker will open

3. Select the color for the background

4. Close the Color Picker
Chapter 7. Map Operations

7.1. Displaying the Scale

You can display the scale for the Map currently showing in the Map Window. To show the Scale box, Map → Show scale. A small Scale box appears in the lower right-hand corner of the Map window. Notice this Scale box gives the current scale, and changes as you zoom in and out of the map.

7.2. Trimming Maps

Trimming maps allows you to take a map that contains more information than is necessary for your task and make it smaller. You can trim a full map to a selection window that you make, or trim a map based on the smallest map possible containing all of the feature on a given map.

Procedure 7.1. Trimming a Map to a layer’s extent

1. Select the layer in the Layer Stack
2. Choose Map → Trim Map to Extent of Selected Layer
   Cartographica will remove all data outside of the extent of the selected layer from the map on all layers

Procedure 7.2. Trimming a Map to a feature's extent

1. Select the layer in the Layer Stack
2. Select one or more features to trim the map to
3. Choose Map → Trim Map to Extent of Selected Features
   Cartographica will remove all data outside of the extent of the selected features from the map on all layers

Procedure 7.3. Trimming a Map to a feature's area

1. Select the layer in the Layer Stack
2. Select one or more features to trim the map to
3. Choose Map → Trim Map to Area of Selected Features
   Cartographica will remove all data not included within or touching the area of the selected features

7.3. Changing the Projection of a Map

You can change the projection in the map window. This doesn’t change the underlying data in any layer, it just coerces the data into that projection for display and output purposes. Any change you make here affects all of the Layers in the map and will persist until the change is made again using the same method.

The projection of a map is a way of representing map data on a plane (a “flat” map) either on screen or on paper. All map projections distort the surface in some way. Depending on the purpose of the map, some
distortions are acceptable and others are not; therefore different map projections exist in order to preserve some properties of the original shape in the flat map representation. You can choose from different projections to see which more accurately represent your data and which compromises are most acceptable to you. You decide what the projection will be. Some representations of projections include the United Kingdom using the British Grid or Equal Area Projections giving maps of the United States that "curved" look or even using different map projections to give a 3D look to a map like you might see on a GPS display.

To change the target projection of a map:

1. **Map → Project map.**

   The Project Map dialog appears.

   ![Figure 7.1. Project Map Window](image)

   **Figure 7.1. Project Map Window**

2. From the left side of the dialog, choose the map projection that best suits your needs.

   The **Description** box on the right will change depending which projection is selected. You can also click the **Specifications** tab to see additional details about the selected projection.

   Below this informational area there is a small preview area that gives a general orientation for the features of your map once the selected projection has been confirmed.

   You can use the search/filter box to find a particular projection (or group of projections) and narrow down your choices. As you type in the search box, the projections that do not match the search criteria are automatically removed, creating a smaller list from which to choose.

3. Once you have the selected the projection that best suits your needs and most accurately represents the data you are attempting to display, click **Set**.
7.4. Showing Information About the Map

To show information about the map layers Map → Map Info.

The Map Info Window appears.

![Map Info Window](image.png)

**Figure 7.2. Map Info Window**

This window shows the data about each layer in the map and also general data about the entire map such as number of points and what the geometry types of each of the points. When you click on the Layer in the left-side window, the data in the right-side window changes to show the information for the selected layer.
Chapter 8. Analyzing Data In Cartographica

8.1. Introduction to Cartographica Analysis

Cartographica’s second calling, behind importing and displaying data, is analysis of that data. There are many options in the Tools menu for performing analysis and we will be adding more as time goes on.

There are two basic kinds of analysis functions, grouped by the type of resulting data. Analyses that result in a raster layer provide smooth visual outputs and selectable color maps, etc. Analyses that result in either new vector layers or modifications to existing vector layers provide high levels of scalability and are often more useful for further analysis. Some functions may be able to output either vector or raster data.

8.2. Making a Kernel Density Map (Raster)

Kernel Density Maps are a way to look at the relative density of point data as spread over an area. The Cartographica Kernel Density Map option uses a highly-accurate Kernel for its analysis. By default, the kernel density analysis uses a set of “reasonable” parameters, however an advanced version of the feature is available by holding down the Option key on your keyboard while selecting the menu item that allows you to change those defaults.

You can make a Kernel Density map on any point layer. This creates an analysis layer (basically a bitmap, at least visually, but it’s actually a “cell” system where each “cell” contains the value for the area bounded by the rectangle the cell contains).

Depending on your particular data, you may find it helpful to either move this layer to the bottom of your layer stack, or use the Styles item to change the layer opacity to be more transparent.

To create a Kernel Density Map using the default parameters:

1. From the layer stack, select a single point layer in your mapset for which to analyze the density.
2. Select the Zoom level for the Kernel Density Map in the Map window by zooming in to the view you want. The default Kernel Density analysis is performed on the area in the Map View at time that you select the command.
3. Choose Tools → Make Kernel Density Map

After the analysis is complete, the graphical map will be added as a layer to the mapset.
To create a Kernel Density Map specifying the precise parameters:

1. From the layer stack, select a single point layer in your mapset from which to analyze the density.
2. Select the Zoom level for the Kernel Density Map in the Map window by zooming in to the view you want.
3. Hold the Option key and choose Tools → Make Kernel Density Map…

The Kernel Density Map Options window appears.

Select the options for this analysis:
• **Target Layer** is the point layer to be analyzed.

• **X Cell Count, Y Cell Count, Width,** and **Height** provide a way to change the number (and thus size, or vice versa) of the cells used in the calculation. The width and height parameters conform to whatever the target layer’s projection is, so if the projection is in State Plane (feet), feet will be the size. Cartographica analyzes the field using a grid of cells spread evenly across the field. By setting the count of the grid cells, you can determine the coarseness of the grid that is used.

To change this, either choose the width and height in number of cells, or in map units (here in the example, it’s in degrees, but if your map layer’s CRS is set to feet or meters, the parameter will be in those units).

If the **Keep Proportionate** check box is checked, Cartographica will adjust the width to match the height you enter, and vice-versa. For a disproportionate grid, then uncheck the box.

• **Fit grid to** allows for adjustment of the coverage area of the grid to one of the following:
  - **Layer Bounds** constrains to the data in the layer.
  - **Map Bounds** constrains to the entire map.
  - **Visible Map Area** constrains to the area currently shown on the map view (where this is useful if you want the KDM to go beyond the boundary of the current map to provide some context by means of a smooth drop-off.

• **Kernel** allows for the specification of the kernel used for the analysis

**Table 8.1. Available Kernels**

<table>
<thead>
<tr>
<th>Kernel Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal (Gaussian)</td>
<td>Unbounded. Each data point contributes something to every cell</td>
</tr>
<tr>
<td>Quartic (or Spherical)</td>
<td>Bounded. Approximates the normal with a constant k.</td>
</tr>
<tr>
<td>Exponential (Negative)</td>
<td>Much more weight is given to the center points</td>
</tr>
<tr>
<td>Triangular (Conic)</td>
<td>Linear decay with distance</td>
</tr>
<tr>
<td>Uniform (Flat)</td>
<td>Bounded. Value is k or 0</td>
</tr>
<tr>
<td>Paraboloid/quadratic (Epanechnikov)</td>
<td>Bounded, more spread out than <strong>Quartic (or Spherical)</strong> and used in ArcGIS</td>
</tr>
</tbody>
</table>

• **Intensity** and **Weight** allow you to assign columns in the layer from which these values are retrieved. Without changing these parameters, the defaults are to use an intensity and weight of 1.0, which gives each point equal weight. These two values are multiplied and then added into the cell for the map. Thus, a cell that contains a single point with a weight of 2 and an intensity of .5 has a value of 1.

For example, if you have data that is a list of duck-blind positions with the number of ducks seen in a one hour period, you would set the intensity to the count and that would give you an idea where the ducks are concentrated.

• **Bandwidth** is the radius of the band that the point affects in cells and determines the decay of the value from the central point. If the bandwidth is set to 8, then little or no effect will be generated by the 8th cell from the point. If you set this number larger, the effect will spread out to a wider radius.
• k is a parameter specific to a particular kernel function. See Table 8.1, "Available Kernels” for details.

4. Once you have made your selections click Analyze and the Kernel Density Map is created and added to the map as a new analysis layer.

8.3. Making a Convex Hull

Convex Hulls are geometric shapes that represent a completely convex "hull" or wrap around a set of data. They are created using vector polygon layers. If you select multiple features, Cartographica will generate the Convex Hull around all of the features as a set. If you instead select a layer with no selected items, the entirety of the occupied layer will be used as points to create the hull.

This works with all geometries, except a single point selection.

Procedure 8.1. Creating a convex hull

1. Select the Layer that contains the points to add to the Convex Hull.

2. Choose Tools → Make Convex Hull for Selection. Default parameters are used to create the graphic.

The Convex Hull appears on the Map encompassing all of the points you selected in the Data View, or the entire layer if you have not chosen any more specific points.

A sample Convex Hull looks like this:

![Figure 8.3. Sample Convex Hull](image)

8.4. Creating Buffers around Map Features (Vector)

Buffers are a very common and useful tool employed for data analysis. In it’s simplest form, a buffer is an area created around a feature (point, line or polygon) which keeps the basic shape of the original feature, but expands the size of the feature by some amount.

Buffers are often used around points to create a survey area. For example, you might create a buffer of 500 ft radius around a set of points representing schools in order to analyze the number of banks within 500 ft of schools.
Under some circumstances, negative buffers (buffers which are inset from the border of a polygon) are used to determine internal information about a set of polygonal features. Negative buffers may not be used with points or lines.

**VISUAL EXAMPLE**

**Procedure 8.2. Create Buffers**

1. Select the features you want to create the buffer around

2. Choose **Tools → Create Buffers**

   The Create Buffers sheet appears.

![Create Buffers sheet](image)

**Figure 8.4. Create Buffers sheet**

3. If you want to create buffers in the coordinate system of the original features instead of the map, check the box next to **Create buffers in original features’ projections**. This is not a common operation, as it can cause the buffers to appear irregularly shaped.

4. • Select the distance that the buffer is created around the features as a number (using the **Uniform Width** field. Units will be displayed to the right of the box and if the units are linear, it is possible to set the units using the pop-up menu next to the box.

   • Select the distance (radius) that the buffer is created around the features as a **Width by Column** to have the current value the specified column determine the radius.

   Cartographica currently expects this column size to be scaled to the units of the layer. In the case of latitude and longitude, that's degrees, in other cases commonly feet or meters. The units will be displayed, and if the units are linear, it will be possible to change them using the pop-up menu next to the **Uniform Width** box.
5. Check Copy Feature Data to Buffer if you want each attribute of the feature being buffered to be copied to the resultant buffer.

6. Click Buffer....

Cartographica creates a buffer area around the points, lines, or polygons that are in the selection or selected layer and saves them into a new layer.

Very large and complex geometries with small buffer sizes can take a long time to resolve.

8.5. Counting Points in Polygons

You can also use Cartographica to count the number of points from the target layer that are entirely enclosed within each polygon in the base layer. In particular, this includes the ability to find out how many points are contained in a particular area.

Procedure 8.3. Count points in polygons

1. Choose Tools → Count Points in Polygons.

The Count Points in Polygons Options dialog appears.

2. Select the layer containing the data you want counted from the Count Points From drop down menu.

Only point layers will be available

3. Enter a name for the new column in the New Column Name field.

4. Click Count.

The selected points are counted and appear in the data window in a column named as you specified.

8.6. Adding Data Columns

Cartographica contains a number of features to quickly analyze and add columns containing information about your geospatial data. We’ll briefly touch on each mechanism and procedure to do these
Procedure 8.4. Adding Coordinates Columns for Points to the layer

This function adds coordinate columns (X, Y, and optionally Z and M) from the selected point layer. These data are added to your data table. To add coordinates columns,

1. Select the target layer in the layer stack
2. Tools → Add Coordinates Columns.

Procedure 8.5. Adding an Area Column to the layer

1. Select the target layer in the layer stack
2. To add an Area column, Tools → Add Area Column.

Procedure 8.6. Adding a Length Column to the Layer

1. Select the target layer in the layer stack
2. To add an Area length column, Tools → Add Length Column and the column is added to the layer.

You are adding a length column that displays the length (in layer units) of the lines in the line or polygon. It is important to note that complex features (polygon layers) have all of their lines summed total length of all line segments in the polygons, but are measured as their actual length, not as a string of points.

For example if you have a complex line which contains a line from San Francisco to Salt Lake and a line from St. Louis to Washington, DC, the length of that line is the sum of the two lines, not the total distance from San Francisco to DC stopping in Salt Lake and St. Louis.

For polygons, the data is the length of all line segments in each line. So a polygon with a hole (donut) will have a length equal to the length of the exterior border of the donut plus the length of the interior border of the donut.

Procedure 8.7. Adding a Midpoint Coordinates Column to the Layer

1. Select the target layer in the layer stack
2. You can add the coordinates of the midpoints of selected line (only) layers. You are essentially adding midX and midY column showing the midpoint of the lines contained in each feature.

To add a midpoint coordinates column, Tools → Add Midpoint Coordinates Column.

If used with complex lines (such as lines with a gap), the midpoint shown will be half-way along the total distance of the line. In the example used in Adding a Length Column, the “midpoint” will actually appears as east of St. Louis, since the line from San Francisco to Salt Lake City is shorter than the line from St. Louis to Washington, DC.

Procedure 8.8. Adding a Centroid Coordinates Column to the layer

1. Select the target layer in the layer stack
2. You can add columns for the coordinates of the centroids of the selected polygon layers. Adding Centroid columns works only with Polygons.
The centroid is the center of gravity of the polygon. If you have a unit square, the centroid will be at .5,.5. If that unit square has a hole that is off center, then it won’t be. Note also that in the case of complex polygons or polygons with concavities, the centroid may be outside of the polygon. However, it is always within the extent of the complex polygon. This adds cenX and cenY columns to the selected layer.

To add Centroid Coordinates Column, **Tools → Add Centroid Coordinates Columns.**

**Procedure 8.9. Adding a Column showing the Distance to Nearest Feature**

You can calculate the nearest distance between the points in a point layer and the features in another layer. This can be used to calculate nearest neighbor to objects in the same layer or nearest distance to points, lines, or edges of polygons.

It is not only possible, but often desirable to add distance to the nearest points in the same layer. In this case, you must be careful to change column names if you want to add any data columns from the source. Otherwise, you may overwrite the original data with the data from the nearest feature.

Distance to polygons is the distance to the nearest edge and does not treat specially the case of being ‘inside’ of a polygon. So, if your point is 5 meters inside of a polygon, the distance will be 5 meters from the polygon, just as it would be if the point were 5 meters outside of the polygon.

1. Select the target layer in the layer stack
2. Choose **Tools → Add Distance to Nearest Feature.**

The Distance to Nearest Feature sheet appears, showing the **Target Layer** into which the distance is to be added.
3. Choose the layer whose features you would like to measure to with the Calculate Distance to pop-up menu.

4. Enter a name for the new column in the Distance Column box.

5. Optionally, select columns to copy from the Calculate distance to layer to the Target Layer by checking the Copy box next to the column name and changing the resultant column name (if desired) by putting a new value in the Copy Name column.

Columns that exist in the Target Layer are used when copying data, so be careful to change the column name if you don’t want to overwrite data in the existing layer.

6. Click Add… to create the column and perform the calculation.

8.7 Geocoding Addresses

Another form of analysis that Cartographica performs is Geocoding, or GEOgraphic enCODING of data that is not native GIS data. Although similar in some ways to the process of importing other data, there are two special kinds of data we will treat separately: addresses and photos.

Cartographica has two distinct, and powerful, address geocoding capabilities. Prior to version 1.2, Cartographica provided geocoding based on address information that was already in the map. This was usually street information received from a government agency or a data provider. More recent versions of Cartographica have also added the ability to geocode using Bing Maps geocoding services. This service provides
high-quality, constantly-updated geocoding capabilities for addresses in a large area of the world. Although it is easier to set up, there are reasons why you might not want to use it for geocoding. Some of these reasons include: historical geocoding, where the data that you are geocoding uses streets that no longer exist or have been realigned since the

### 8.7.1. Bing Geocoding

Using the Bing geocoder removes most of the configuration headache from the process of geocoding. In many cases, it is more up-to-date than files that you can obtain about the area that you are geocoding and it is certainly easier to configure.

**Procedure 8.10. Configuring Bing Geocoder**

1. Choose **Tools → Geocoder Options**…
2. Select **Bing Geocoder** tab and click **OK**.

   You are now ready to geocoder in this map.

### 8.7.2. Internal Geocoding

Geocoding is a complex function and requires all the right data be in place to do it well. Cartographica has a powerful Geocoding capability, but to use it, you must gather data first. Most data is accurate to the last census update and may be more recent, based on the government’s move to modernize and increase accuracy in the data or your commercial source. Keep in mind that if you are trying to geocode an old address, your accuracy may suffer if the data is too new, since some street realignments, renaming, renumberings, and removals may have changed the landscape since the address data was taken.

First, you need to figure out the area of your search. Generally speaking, you want to limit geocoding to a limited number of counties, to reduce the amount of work necessary on your computer. However, if you must do a large area, or if your area is undefined, there are geocoding services that can do bulk geocoding for a small fee.

**Procedure 8.11. Preparing to geocode with TIGER data**

1. Locate the TIGER files on the Census Bureau web site. First, go to the TIGER home page, then select the particular year you're interested in. To use these files, go to the Bureau's site and download the “All Edges” shapefile and then follow the usual instructions for geocoding.

2. Locate your TIGER/LINE 2006 files on the server and download the county or counties that you are interested in using for geocoding. After unzipping the files, choose **File → ImportVector Data** and then select the .RT1 file for import. This will import all of the TIGER data for that county. Because of the size of some of these files, it can take a few seconds to a couple of minutes to process them for import.

3. Once the data is loaded, you may remove any superfluous layers unless you need that data for another purpose. The only layer required for geocoding will end in "(Complete Chain)". Once you have prepared the map with the geocoding layers, you may want to save the Map file from Cartographica so that you can use it for geocoding that area in the future, without having to go through the download and import process.

4. If you need to geocode more than one census area, you may either merge the two layers into a single layer and use the new layer as the geocoding layer, or to run the geocoder twice, once with each layer selected.
5. The next step is to configure the geocoder. **Tools → Geocoder Options.** If you are using standard TIGER/Line or TIGER/shape files, Cartographica should set up the geocoder automatically. In most cases, not only is the layer determined, but the field names are chosen as well. If you are using a file from a different source, or of a different vintage, you may need to set up the individual field names. At a minimum, Cartographica requires: Numbers From and Numbers To (for either side of the street or both), the Street Name, and Street Type (Rd, Ave, etc.). Each of the other entries (prefix and suffix, zip codes, state, and city) are optional but will increase the accuracy. In the case of City or State, you may type in value to match the City or State section of the address.

However, it is not a requirement to use TIGER files for geocoding. The need is to have a minimum set of parameterized lines. Any line layer can be selected as the Geocoding layer.

**Procedure 8.12. Configuring Internal Geocoding**

1. Choose **Tools → Geocoder Options.**

   The Geocoder Options window appears.

   ![Figure 8.7. Geocoder Options](image)

2. From the **Geocode using layer** menu, select the layer that has the attributed lines in it.

3. Each of the geocoding fields in this dialog provides a more specific way to find the data.
For each field in the geocoding layer that you want to match to addresses, select an appropriate Geo-
coding Fields entry and choose the corresponding field. Generally, the more fields that you use, the
more precise the geocoding will be. However, there are times when avoiding certain data fields is ap-
propriate due to inaccurate data or the format of the original addresses.

The most important features are **Street Name**, **Street Type** (ave, rd, street, etc.) and **Numbers From**
and **Numbers To** on the right and left sides of the street (indicated by the left and right columns). If
you have these at a minimum, your data will probably geocode pretty well.

If you have **Zip Codes** for the left and right sides, those can help make things noticeably faster when
working with large sets of lines.

4. If you have data for only one state and the data does not contain a state column, type in the state ab-
breviation in the **State** field to automatically exclude any addresses not in that state.

5. Once you have selected all of the geocoding options, click **OK**.

Once you have set up geocoding, you can use it for the **Import Tabular Data** or **Acquire Database Data**
features. Each of these have options to read the data as addresses and then geocode them.

### 8.7.3. Geocoding Your Address Book

As an easy demonstration of Cartographica’s geocoding abilities, you can geocode your address book with
a single command once you have configured the geocoding.

**Procedure 8.13. Geocoding your address book**

1. Set up the Geocoder options properly.

2. **Tools → Geocode Address Book Entries** all of your address book entries will be geocoded.

### 8.8. Geocoding Photos

Geocoding photos is a way to take photos and place them on a map in Cartographica. Once these have
been placed, they can be displayed as the point representation of a feature, or displayed when browsing the
map by clicking on point.

There are two ways to geocode photos:

- import files that have already been coded with geospatial data (usually latitude and longitude and using
  the EXIF extensions to the JPEG file format)

- using the time code on digital photos to coordinate with information gathered by GPS devices to determine
  location

Cartographica currently supports both the import form and the timecoding form, imported either from
files that you select or from inside of iPhoto. Photos originating from some cellular phones, such as the
iPhone, and from some recently released cameras with GPS capabilities are the most likely sources of
photos that are coded with location.

### 8.8.1. Importing encoded photos

This process is simple because the photos already contain all of the necessary information to put them on
the map.

1. If you are bringing in photos from iPhoto, choose **Tools → Plot GPS Encoded Photos from iPhoto…**. Then, select the pictures from the browser and click the **Import**.

2. If you are bringing in photos from photo files, choose **Tools → Plot GPS Encoded Photos** and select the picture files in the file window.

2. Choose **Tools → Plot GPS Encoded Files**

3. Select one or more files to import and plot into the existing map and click **Import**

Once Cartographica has loaded and coded the files, they will appear in a new layer on the map, with the location of each photo represented by a point feature.

8.8.2. Timecoding Photos

The process of importing photos using this method is a bit more involved due to the need to synchronize the clock information between the camera and the GPS device. If you expect to do this regularly, we suggest setting the camera’s clock to the same time as the GPS whenever you turn on the camera, or at least once per day. You may also find it useful to set the time on the camera to GMT, as that is the native time of GPS and therefore requires the least amount of conversion.

Procedure 8.15. Importing photos by matching photo times and GPS tracks

Because the process is dependent upon the coordination between the camera and the GPS device, we describe the steps here from the beginning of the photo safari to the placement of the photos on the map.

1. Sync the time on your camera to the time on your GPS device.

   Alternatively, record the difference between the times. This is easy if you can use your digital camera to take a picture of the time on your GPS when you start taking photos. However, if your GPS has no screen, then you should sync to GMT, which is the native time format for GPS data.

2. Take pictures.

3. Download the tracks from the GPS.

   Choose **File → Acquire GPS Data** to bring data in directly from your GPS.

   Choose **File → Import Vector Data** to bring in an existing GPX or other exported data file (such as those made by ClueTrust’s LoadMyTracks [http://www.loadmytracks.com]).

   If you are bringing in more than one track file (this might happen on multi-day trips, for example), you can merge the tracks together by selecting the tracks as a group in the Layer Stack and choose **Layer → Merge Selected Layers**.

4. If you are bringing in photos from iPhoto, choose **Tools → Timecode Photos from iPhoto…**. Then, select the pictures from the browser and click the **Import**.

   If you are bringing in photos from photo files, choose **Tools → Timecode Photos**… and select the picture files in the file window.

5. Click **Import** and watch Cartographica plot your photos onto the map.
The result is a new point layer containing references to each of the photos placed on the map based on matching the time and the location.

Unlike geotagging software that writes information back to the file, Cartographica makes no modifications to the original photo files themselves, guaranteeing the safety and integrity of your image files.

When selecting a point in a layer with photos, you can see a full sized version of the photo by bringing up the Image Viewer by choosing Window → Show Image Viewer.
Chapter 9. Working With Raster Layers

9.1. Merging Raster Layers

You can use Merge Raster Layers when working with raster data (such as satellite imagery from Landsat) that is split into separate layers for each color component. When using this data to show visible light, the layers (usually Red, Green, and Blue layers) must be merged into a single layer.

Procedure 9.1. Merging Raster Layers Automatically

1. Select the Raster Layers you want to merge.
2. Choose Tools → Merge Selected Raster Layers.

Cartographica takes the selected layers in the order of the layer stack as Red, Green, Blue, and optionally alpha. Alpha is equivalent to transparency/opacity, where the minimum value is completely transparent, and the maximum value is completely opaque.

When merging layers manually, you have control over which layers to use, which can be helpful in re-arranging layers or in creating effects by using the same layer in more than one color band.

Procedure 9.2. Merging Raster Layers manually

1. Select the Raster Layers you want to merge.
2. Hold down the Option key and choose Tools → Merge Selected Raster Layers

The Merge Raster layers Options dialog appears.

![Merge Raster Layers Options dialog]

Figure 9.1. Merge Raster Layers Options dialog

3. For each layer that you want to use, select a Raster Layer from the pop-up. Each layer may be selected zero or more times.
4. Check Remove Used Layers to delete the original layers once they have been merged. Leave it unchecked to leave the layers in place.
The original files on disk are not affected by the merging and will not be removed regardless of this setting.

5. Click **Merge** and the layers are merged and the new layer appears in the Layer stack.
Chapter 10. Editing Features

10.1. Editing and Adding Features

In some cases, you need to add geospatial data to a layer without exacting precision. Cartographica supports manual editing (and creation) of features in new and existing layers in order to facilitate this.

Feature editing is done in Edit Mode, where your changes are only temporary until you commit them. In edit mode, all of the layers (including the one containing the feature you are editing) are “ghosted” behind the editing area so that you can still make out where in the coordinate space you are, but those features don’t interfere with your navigation and editing.

When in edit mode, all navigational and zooming features are still available, so feel free to do things like Zoom To Feature or pan around in order to make your working canvas as appropriate as possible.

Individual points in features are shown using red dots. When these points are selected, the dots become hollow (have a white circle inside of them) to mark the selection. New points are inserted next to the currently selected point by holding down the Option key and clicking your mouse.

Procedure 10.1. Editing an existing feature

1. Select the layer containing the feature you want to edit in the Layer Stack
2. Select the feature to edit in the Map View
3. Choose Edit → Edit Selected Feature.
   (or double-click the feature when you are using the Identify icon in the Map pane)

The map pane goes into Edit mode. When you are in Edit mode, a partially transparent backdrop shows up behind the features you are editing to allow you to discern between what you’re editing and the rest of the map. The color and opacity of this layer can be adjusted (see Procedure 10.3, “Changing Edit Backdrop Color”). The original shape is also shown in the editing background. Here is an example of what the map window looks like in Edit mode.
4. Now you can change the geometry of the selected features. For example, you could move the location of a city or the path of a road.

There are certain restrictions placed on Cartographica while you are in Edit mode:

While in Edit mode:

- Holding the Option key on your keyboard and clicking your mouse adds a new point after the currently selected point.
- Pressing the Delete key on the keyboard or choosing Edit → Delete will delete the selected point.
- Multiple points may be selected at the same time and will move in unison.
- Using the arrow keys will move the selected point in the appropriate direction (autorepeat is enabled).
- To close a polygon, commit changes with it still open. Cartographica will add a terminal point at the same location as the origin.
- All zoom controls function normally, except typing in the zoom box.

5. To save (commit) your changes after editing, press Enter on the keyboard or choose Edit → Edit Selected Feature again.

- To cancel your changes, press the Escape key on the keyboard.

Undo is handled separately when editing to preserve as much context as possible. So, when in edit mode, the undo/redo are used for each individual editing operation (like moving, deleting, or adding a point). Once you leave the edit mode (assuming you accepted the changes), these steps are forgotten but you will be able to undo the entire editing operation.
Once you have exited out of Edit mode and saved your changes, the changes are reflected in the Point Data window.

Procedure 10.2. Adding a New Feature

1. Select the layer where you want to add the feature in the Layer Stack
2. Choose Edit → Add Feature
   
   If the selected layer has no content (and therefore isn't associated with a particular shape type), you are prompted for whether the new shape layer will be a point, line, or polygon.
   
   The map pane goes into Edit mode just like when editing a feature. The same constraints apply to adding a feature as when editing a feature.
3. To add a new point to a feature in editing mode hold the option key on the keyboard and click to add the point.
4. To save your changes after editing, press Enter on the keyboard or from the Edit menu, select Edit Selected Feature again.
   
   To cancel your changes, press the Escape key on the keyboard.

Once you have saved your changes and exited out of Edit mode, the features you have added to the layer are viewable in the Point Data window.

Procedure 10.3. Changing Edit Backdrop Color

1. Choose Cartographica → Preferences… to bring up the Cartographica Preferences window
2. Click Edit Backdrop Color color well
   
   The Color Picker will open
3. Select the color for the editing backdrop
   
   The Opacity slider determines how much of the background layer shows through to the editing view. To hide all other features, set Opacity to 100%. To disable the Edit Backdrop layer, set Opacity to 0%.
4. Close the Color Picker

Occasionally, geospatial data needs to be corrected by changing coordinates to be more accurate. In these cases, changing values directly in the point window might be more appropriate, especially when correcting obviously erroneous data.

Cartographica has the ability to change any existing point in any feature using the Point Data window.

Procedure 10.4. Precision Editing Features in the Point window

1. Select the layer in the Layer Stack
2. Select the data you want to change (either in the Data View or Map View)
3. Choose Window → Show Point Data
   
   The Point Data window appears showing the currently selected feature's geometry.
4. To change a point, click on a coordinate and type in a new coordinate value.

5. If you need to add or remove a point, select the line containing the point and use the + and - buttons to add or remove it. Of course, undo is available to undo whatever changes you have made.

Points are always edited in their original projection (CRS), so if your map is displayed in state plane, but the data you’re editing is in Lat/Long, the editing will be in Lat Long unless you Reproject the points in the layer.

10.2. Merging and Splitting Features

You can use the Merge Selected Features command to join geometries. This will work best for overlapping geometries, as they will result in a single part. If the parts are discontiguous (even if in a very small way), then they will be considered separate parts and you will end up with a multi-part geometry. There are two modes for this selection: intersection (features where any point is contained in the selection area) and containment (features where all points are contained in the selection area). REWRITE

Procedure 10.5. To merge selected features into one

1. Select the features you want to merge.

2. Choose Edit → Merge Selected Features

The features you have chosen are merged onto one feature containing each of your selections. The previous geometries will be removed.

Procedure 10.6. Splitting a multi-part feature into separate features

1. Select the feature to split
2. Choose **Edit → Split Selected Features**

The feature you have chosen will be split into one new feature for each independent part in the existing feature. All feature data will be copied to each newly created feature. The original feature will be removed.

In the case of complex polygons with islands and holes, the islands will be separated into new features and the holes will be assigned to the closest encompassing island.
Chapter 11. Exporting Data

One of the benefits of having a desktop GIS is the ability to output data in a number of formats. Cartographica has extensive export capabilities to provide for just this type of operation. Generally, Cartographica can export entire Maps or just individual layers (or selected data within those layers). Which option is right for you depends on what you’re trying to achieve.

11.1. Exporting Entire Maps

Cartographica can export Maps in a number of formats including (but not limited to):

- ESRI Shapefile
- GML
- KML
- MapInfo TAB
- MapInfo MIF
- Atlas BNA
- Adobe Illustrator

This will export the entire map either as a single file (if the format allows) or as one file per layer (if the format only handles single layers). You can also choose to not export invisible layers, to reduce file size and complexity.

Procedure 11.1. To export an entire map

1. Choose File → Export Map
2. Select the export format from the Export Format menu
3. Check Export Visible Layers Only to limit the exported data to layers that are currently visible.
4. Choose a file name for the export and click Save

Warnings will show up in the export window to describe certain aspects of the exported data:

- **CRS can’t be saved, map will be re-projected to native CRS**: The target format doesn’t support multiple CRS’s and the CRS that you are currently using doesn’t match it’s format, so Cartographica will transform the data appropriately before writing it out.

- **Format doesn’t support multiple geometries**: A file will be created for each layer

- **Data fields won’t be importable**: data tables can’t be exported and won’t be importable as data into other programs.

- **Some geometries won’t be accurate**: the selected file format doesn’t have accurate ways to save all geometric types, so this format cannot be used to import data later. Cartographica will produce output that is as close as possible to what you see on the map display.

- **CRS can’t be saved**: the file format is device-independent and there is no place to indicate what format the data is in.
Format does not support layers: Groups of features of specific types will be indistinguishable from other groups. There is support for multiple kinds of features, but not layers. As such, a single file will be created, but all polygons will be in a single polygon store, same for points and lines.

11.1.1. Exporting Maps to KML

When exporting to KML, all data is exported as data in the layers. However, much of that data is not understood by Google Maps or Google Earth. In the future, it is possible that other programs will understand it. Cartographica exports the feature names based on either the default feature name, the label, or the feature ID. The data that shows up when you click on a feature in Google Earth or Google Maps will be either all data or just the data selected in the Layer Info Pop-up box. Cartographica exports all layers in their current hidden/shown state unless Export Visible Layers Only is checked.

Here is a figure showing our example map and data of Canada exported to KML and then opened in Google Earth. You can see the convex hull in eastern Canada as well as all of the roads that existed in the original map in Cartographica.

![Figure 11.1. Cartographica map exported to KML and opened with Google Earth](image)

Procedure 11.2. Setting display fields for KML Export

1. Choose Windows → Show Layer Info to bring up the Layer Info window
2. Click on the Fields tab to show the field information
3. For each field that you would like to be displayed in the KML pop-up, check the Popup box.

   This same box controls what information is displayed when Map → Show Data Tooltips is selected.
Procedure 11.3. Setting the name of features for KML Export

1. Choose **Windows → Show Layer Info** to bring up the Layer Info window

2. Click on the **Info** tab to show the general layer information

3. Choose the column name from the **Feature Name** pop-up

   This same pop-up controls what the name of the feature when **Map → Show Data Tooltips** is selected.

11.1.2. Exporting Maps to Adobe Illustrator

Exporting data to Adobe Illustrator is very similar to exporting to KML. All of the data is exported, but Illustrator can’t always see it. The Features are named using the same technique as in KML above.

Cartographica exports each layer in the map to a separate layer in the Adobe Illustrator file. If the layer has labels, a separate Illustrator layer is exported just for the labels (allowing you to toggle these labels on or off as necessary after exporting). Finally, Cartographica exports a legend for each layer in the map, providing the basic style key for designers who use the Illustrator files.

When exporting to Illustrator, Cartographica also has the ability to embed the data for the layers into the Illustrator file, which is useful when working with third-party plugins, such as Avenza MAPublisher [http://www.avenza.com/mapublisher]. ClueTrust and Avenza have been working to make sure that maps exported from Cartographica and imported into Illustrator when using MAPublisher are easy to manipulate and full of rich data. As such, when you check the **Include data in export** box while exporting to Illustrator, georeferencing, CRS (Projection) and column data is exported along with the feature data and the styles.

Here is an illustration of a map of Canada exported and then opened in Adobe Illustrator CS5.
11.2. Exporting Layers and Features

For some purposes, it is important to export only feature data, such as cases where you are sending data off for further processing or research using another GIS.

Cartographica exports individual features in ESRI®’s Shapefile format.

Procedure 11.4. Exporting an individual layer or selection

1. Select the Layer that you want to export from the Layer Stack
2. Choose **File → Export Layer Features**
   - Choose **File → Export Selected Features** if you want to export just the selection.
3. Optionally select the character set (UTF-8 will be the default.)
4. Enter a file name and click Save.

11.3. Exporting A Web Map

One unique feature of Cartographica is the ability to create a click-able web map from geospatial data. By using the layers of the map to create a web-compatible image file and then using the data in the data table,
it can make each click-able area correspond to a link on the site or on another site. It can also provide roll-over text.

**Procedure 11.5. Creating a web map**

1. Choose **File → Export Web Map**.

   The Export Web Map sheet appears.

   ![Figure 11.3. Export Web Map Sheet](image)

2. You will be prompted to provide the following information:
   - **Selection Layer** - The layer which is used to bound the selections. This will be a polygon layer.
   - **URL Column** - The column that contains the URL (if any) that should be the target of the link.
   - **Label Column** - The column that contains the label to be used for the target of the link.
   - **File Format** - The type of image file (JPEG, GIF, TIFF, or PNG) to create for the map.
   - **Width and Height** - The dimensions of the map to be produced.
   - **Quality (JPEG Only) slider** - If you have chosen JPEG as the file format export format, the Quality slider allows you to choose the level of quality for the output image. A lower quality also guarantees a smaller (byte-wise) image.

3. Once you have set all of the information options, click **Export**.

   Two files will be created for you: an image file and an HTML file in UTF-8. The HTML file contains the geometric information and the links which serve as the basis for a web page that will contain the map.

**11.4. Exporting Maps as Pictures**

Occasionally, you will need to take a map from Cartographica and produce an image file from it in order to include it in another document or use it in some other manner. Cartographica provides an easy mecha-
anism to create georeferenced images that accurately portray the data on the Cartographica map at the time.

**Procedure 11.6. Export a Map as Picture**

1. Choose **File → Export Map As Picture**…
   
   The Export Map As Picture sheet appears

   ![Figure 11.4. Export Web Map Sheet](image)

   **Figure 11.4. Export Web Map Sheet**

2. Choose an image format from the **Format** pop-up menu

3. Enter the desired width and height in the appropriate boxes

4. Click **Save**

   The requested image file, along with a world file (usually tfw, jgw, or pgw) and a projection file (prj) will be created in the folder requested.

   Some programs will understand the world files and some will import the prj files, but not necessarily all, so it is often desirable to use a standard CRS when exporting if you plan on importing the file into another spatially-aware program.
Chapter 12. Producing Printed Output

Cartographica has two ways to create printed output: Quick Printing and Map Layout printing.

As one might expect, Quick Printing provides a quick way to create printed output for use either on the screen or in a PDF. It’s no-frills and represents exactly what is currently on the screen.

Map Layout is much more sophisticated printing mechanism which uses a Map Layout document to define the way that the map will look on the printed page. In exchange for the additional complexity, Map Layout provides a way to print more than one map on a page and to add adornments, such as legends, scale, north arrows and more.

12.1. Quick Printing

Quick Printing is the easiest way to print a basic map. By choosing File → Print Cartographica will print a copy of the current map in as large a format as possible for whatever printer you are using. The larger the print area, the more well-defined the printout.

You can print different format maps by using the File → Page Setup command to set and change the size of the paper to use as the destination for the Map Layout.

PDF maps can be created by using File → Print and then using the PDF menu in the Print window to save a PDF file. These files also pay attention to the Page Setup settings.

Procedure 12.1. Quick-Printing the current map

1. With your map open, choose File → Print…

   The standard Print window will come up with a preview area to the left.

2. Choose the image resolution from among the available options

3. If you want to print just the area that was visible in the map window, check Print Visible Extent Only

4. Change any other printer settings and print as you normally would.

12.2. Complex Map Layout

Cartographica has a second format for creating maps intended for production output. The Map Layout document can refer to any Cartographica Mapset file (or combination of files) and can contain maps, titling, scales, and legends. Map Layout documents contain a single page based on the Page Setup.

Cartographica supports scaling the view of the Map Layout so that it can be seen both in detail (zoomed in) and as an overview for large printouts (zoomed out). The size of the page is determined by the Page settings which can be changed by choosing File → Page Setup.

Procedure 12.2. Create a new Map Layout

- Choose File → New Map Layout

   The new Map Layout window will appear, representing your newly created document
The easiest way to add new elements to the Map Layout window is to use the toolbar at the top of the window.

You can also add elements to the Map Layout window through contextual menus, otherwise known as right-clicks or Control-clicks. Control-clicking in most areas of the Map Layout will show a menu which will then provide you with options for editing the information or adding information.

When you open the Map Layout context menu by selecting the map, holding the Control key on the Keyboard and clicking your mouse, this is what the menu looks like.

Figure 12.1. New Map Layout window
Procedure 12.3. Placing a Map into the Map Layout Window

To add a map into a map layout, the map must already be saved to disk. If the map you are working on is not available (named Untitled), you will not be able to add it to the map layout.

1. Using the Add New Map toolbar icon,

   drag a rectangle in the map layout window to the size you want the map to be and release.

   Choose **Insert Map** from the context menu

   The map appears in the window.

2. Adjust the size and location of the Map by clicking once on the Map to select it and then dragging it in the window.

   This is an example of a Map inserted into a map layout.
Once a map is in place on the Map Layout, you may change the map set referred to by the map (and any associated legends and scales) by selecting the map and using the **Change Map** command from the contextual menu to retarget it to any map in a currently open Mapset Document.

You can add multiple maps to the same Map Layout page and they can refer to either the same or different Mapset documents. Scale, pan visible layers in these maps are independent of each other.

**Procedure 12.4. Changing the visible Map area in Map Layout**

Cartographica Maps that are embedded in a Map Layout can be zoomed and panned independently.

1. Click on the Map in the Map Layout window to select it.
   
   This will cause the handles to appear around the map signifying that it is selected

2. Click again on the Map to make it active
   
   The box surrounding the Map will become blue signifying that the Map is now in focus. At this point, many commands for navigating and controlling the Cartographica Map Window now become usable in this map.
3. To zoom the map, use the items in the View menu or use the Zoom Tool (choose Map → Zoom Tool) to zoom the map.

4. To pan the map, choose Map → Pan Tool and then drag inside of the Map to move

**Procedure 12.5. Including or excluding layers from a Map**

Layer visibility in maps in Map Layout documents are handled independently from the more dynamic Map Windows. Initially, visible layers in the Map Window are propagated to the Map Layout copy of the map. Although features are updated live (along with styles), the hidden state of layers is not updated.

1. Click on the Map in the Map Layout window to select it.
   This will cause the handles to appear around the map signifying that it is selected

2. Click again on the Map to make it active
   The box surrounding the Map will become blue signifying that the Map is now in focus.

3. Use control-click (or right-click) to bring up the context menu and toggle each layer with the named entry. Layers which are visible in this particular Map are checked.

Map Layouts are designed for a single page, but that page may be of any size. Choose File → Page Layout to change the page size. Page size changes take effect immediately and provide a good way to target large-format printers.

12.3. Placing adornments in the Map Layout

Once you have placed a map, you may place scales, legends or compasses to further customize the appearance of the printed layout.

**Procedure 12.6. Adding a scale box to Map Layout**

1. From the Map Layout Toolbar, choose the New Scale Box toolbar icon.
   - Choose Add Scale from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Scale to be and release.
   The scale box appears in the map layout window.

**Procedure 12.7. Customizing a scale box**

1. Double-click the scale box
   The Scale Box Options sheet will appear
2. Set **Scale Units** to one of the following:
   - Automatic
   - Standard (auto scale)
   - Metric (auto scale)
   - Or one of the measurements

3. Choose **Fixed Size in Scale Units** to set the length of the scale bar to a particular number of units
   - Choose **Fill Scale Box** to have Cartographica use whatever length comes closest to filling the scale box on the page

4. Click **OK** to apply the changes

**Procedure 12.8. Adding a legend to Map Layout**

1. From the Map Layout Toolbar, choose the New Legend toolbar icon.

   ![Legend Icon]

   or choose **Add Legend** from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Legend to be and release.

   The Legend box appears in the map layout window.

   You can now position or resize the Legend as desired. When you place a legend, items are grouped together in a manner so as to use all the available space efficiently without becoming confusing. If there are multiple styles defined in a single style, they are grouped under the layer name, otherwise, the layer's style swatch appears to the left of the style.

   When there is insufficient space to display all features of the Legend, a yellow warning triangle shows up at the bottom of the rectangle to indicate that there is a drawing issue and that the box needs to be expanded.
Procedure 12.9. Including or excluding layers from a Legend

Legends can contain any subset of available layers in their associated maps. Initially, all visible layers are added to the Legend when it is inserted in the Map Layout. This can be changed after the Legend is added.

1. Click on the Legend in the Map Layout window to select it.
   This will cause the handles to appear around the map signifying that it is selected.

2. Use control-click (or right-click) to bring up the context menu and toggle each layer with the named entry. Layers which are visible in this particular Map are checked.

3. To synchronize with the current visible layers in the associated Map (in the Map Layout document), choose Synchronize with Map from the context menu.

Procedure 12.10. Adding a compass to Map Layout

1. From the Map Layout Toolbar, choose the New Compass toolbar icon.

   - choose Add Compass from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Compass to be and release.
   The Compass box appears in the map layout window.

Procedure 12.11. Adding a Text to Map Layout

1. From the Map Layout Toolbar, choose the New Text Box toolbar icon.

   - Choose New Text Box from the context menu.

2. Drag a rectangle in the map layout window to the size you want the Text Box to be and release.
   The Text box appears in the map layout window.
   You can now position or resize the Text Box as desired.

To change the fonts used in Scale, Legend, and Text items, select the item and then use the Macintosh Font Panel (available from the Edit menu) to change the text attributes.

Here is an example of a Map Layout window with all of these elements added:
Figure 12.5. Scale, Legend, and Text Box added into map layout window

When a map is selected (or one of its related layout features, such as the scale or legend), then all related layout features are badged with a blue dot to indicate that they are related. When not selected, the blue dot disappears.
To move items in the Map Layout, click once on the item to select it (you should see "handles" in each of
the corners and along the edges), and then drag the item to its desired location.

To resize any of the items in the Map Layout, click once on the item to select it and then drag one of the
handles to change the size of the item.

Map Layout items associated with a given Map will show an indicator in the lower-left-hand corner of the
item in order to represent the connection between these items. Thus, if you click on a Scale for a Map that
also has a Legend, all three items will be "badged" as being related to each other.

Some Map Layout items have yellow warning triangles ( ▲ ) when there is something wrong with the
visual presentation. For example, Legends may have this indicator when there is not enough room in the
item to show the entire legend. To fix this, either remove items from the legend, change the font, or resize
the legend box.

**Procedure 12.12. Removing Map Layout objects**

1. Select the object you wish to delete

2. Choose **Edit → Delete**.
Chapter 13. Column Formulas

13.1. Introduction to Formulas

Cartographica supports formulas in columns, providing a way to compute new values from existing columns or from geometric attributes of the feature for which the column is being calculated. The formula interpreter uses an embedded python interpreter with the basic functions plus the math library imported at the base. This chapter lists the functions and constants available.

Cartographica uses an embedded Python interpreter to interpret the formulas, or “expressions” that make up the Column Formulas. This provides an enormous amount of flexibility in these expressions and although we detail the key aspects of python expressions, basically anything that can be executed as a python expression is fair game in a Column Formula in Cartographica.

The simplest expression is just a replacement value. Although it’s not the best use of processing power, it is an effective way to put a constant value in a column as a placeholder.

The most common use of Column Formulas is to create a new value based on the values of another column or columns in Cartographica. To create these simple relationships, use standard arithmetic operators (below) to combine fields.

Example 13.1. Basic Column Formula

For example, a population column and an area column can be combined to determine density.

\[ \frac{\text{POPULATION}}{\text{AREA}} \]

Procedure 13.1. Creating a Column Formula

1. Select the layer in which you want to create a formula in the layer stack
2. Choose Window → Show Layer Info to bring up the Layer Info window.
3. To create a new column in the layer, click on the + button or choose, Layer → Add Column
4. Click on the new column name and change its name to something meaningful
5. Click the Set Formula… button to bring up the formula sheet
6. Drag a column name from the bottom pane to add a reference to another column to this formula. Colors of the column names denote the type of data.

7. Now add the rest of the formula by typing in the formula area and dragging other column references to it.

8. When you are done, click OK to set the formula.

While you enter the formula, Cartographica is constantly evaluating it looking for potential problems and providing you guidance in how to solve those problems. Unfortunately, there are some errors for which Cartographica cannot determine the problem and can only tell you that the result would be invalid.

For other cases, consult the Expression Warnings table for meanings and suggested solutions to problems detected by Cartographica.

Table 13.1. Expression Warnings

<table>
<thead>
<tr>
<th>Warning Message</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>No result value for test data</td>
<td>This expression results in no value. Generally this is the result of calling a function that doesn't return a value</td>
</tr>
<tr>
<td>Math error-some fields may be wrong/missing</td>
<td>This expression evaluates to an arithmetic error using the test data. This warning indicates that under some circumstances (possibly all), field values will not be set. A common cause of this is an expression that results in infinity or attempts to divide by zero using the test data.</td>
</tr>
</tbody>
</table>
### Warning Message | Meaning
--- | ---
Syntax error in formula | This expression is invalid. This is often displayed during typing due to issues such as missing parenthesis, missing operators and other errors.
Interpreter exception | This expression is invalid in a way that we cannot determine.
Geometries can’t be stored in columns | The result of the expression will be a geometry. The most common cause of this is a missing final expression when evaluating a centroid or other geometric value.
Unknown type | The result of this expression will be an unknown type. Because of this, no data will be stored in the resultant column. Check that any functions used in the expression don’t return complex types, such as geometries.
Unknown attribute | The result of this expression references an attribute (using dot notation) that is not known to the interpreter. Check the spelling of anything after a dot.
Unknown symbol: | The referenced symbol is unknown to the interpreter. This is generally caused either by putting two column references next to each other without an operator or by a typo.
Wrong geometry type | A function in this expression that works on a geometry is being used with the wrong type of geometry. For example: you are trying to take the area of a point.
Other geometry error | The expression uses some geometry function incorrectly, resulting in confusion for the geometry processor.
Can’t initialize interpreter | Internal error, please report to ClueTrust

Cartographica does not resolve circular references or directional references. Each column is executed in column order when they are loaded and are updated when they are changed. As such, if you have a Column Formula that is dependent on another Column Formula, you may experience unexpected results.

To refresh an individual value, just set the formula again.

### 13.2. Conditional Expressions

Cartographica supports conditional expressions to provide for complex calculations, such as discontinuous functions. These functions may be nested, so that decision trees can be implemented with great flexibility.

The format for conditional expressions is `true_expression if condition else false_expression`. In this case, the expressions can be any other expression, including a nested conditional expression, so it is possible to create a conditional expression of arbitrary complexity by chaining them together.
Parenthesis around the condition are optional but are useful for clarification.

**Example 13.2. Conditional Function Example**

For example, if you were to need a function that takes a number and rounds to the nearest 500 in the case that the number is positive, but clamps to zero in the case the number is negative, you could write it like this:

```
trunc(VALUE/500)*500 if (VALUE>0) else 0
```

This would result in a value of 0 for all values <500, 500 for all values between 500 and 1000, 1000 for all values between 1000 and 1500, etc.

### 13.3. Mathematical functions

- **int int(any value);**

  \[\text{any value;}\]

  This function converts between any data type and an integer value.

- **float float(any value);**

  \[\text{any value;}\]

  This function converts between any data type and an floating piont value.

- **float ceil(x);**

  \[\text{float x;}\]

  Returns the ceiling of the \(x\) as a float, the smallest integer values greater than or equal to \(x\).

- **float copysign(x, y);**

  \[\text{float x; float y;}\]

  Returns \(x\) with the sign of \(y\). `copysign(2,-1)` returns -2.

- **float fabs(x);**

  \[\text{float x;}\]

  Returns the absolute value of \(x\).

- **int factorial(x);**

  \[\text{int x;}\]

  Returns \(x\) factorial. Fails if \(x\) is not an integer or is negative.

- **float floor(x);**
float x;
Returns the largest integer value less than or equal to x.

- float fmod(x, y);
  float x;
  float y;
  Returns x modulus y.

- float frexp(x);
  float x;
  Returns x with the mantissa and the exponent as separate components of a pair (m,e), such that x=m*2^e. To use one or the other, you must refer to them as a subscript, thus [0] for the mantissa and [1] as the exponent.

- float fsum(any value);(...);
  any value;
  Returns the sum of all values in the list.

- bool isinf(x);
  float x;
  Returns True if x is infinite, False otherwise.

- bool isnan(x);
  float x;
  Returns True if x is the IEEE NAN value, False otherwise.

- float ldexp(x, i);
  float x;
  int i;
  Returns x*2^i.

- float modf(x);
  float x;
  Returns the fractional and integer parts of x as a pair (f,i) such that x=f+i. To use the individual components, they must be accessed by subscript, thus [0] for the fraction and [1] for the integer.

- float trunc(x);
  float x;
  Returns x truncated.

- float exp(x);
float \, x;
Returns e \times x.

- float log(x, base);
  float x;
  float base;
Returns the natural logarithm of x if there is only one parameter. Returns the logarithm of x given base, calculated as log(x)/log(base).

- float log1p(x);
  float x;
Returns the natural logarithm of 1+x (base e).

- float log10(x);
  float x;
Returns the base-10 logarithm of x. Generally more accurate than log(x,10).

- float exp(x, y);
  float x ;
  float y;
Returns x^y.

- float sqrt(x);
  float x;
Returns the square root of x.

13.4. Trigonometric Functions

- float acos(x);
  float x;
Returns the arc cosine of x, in radians.

- float asin(x);
  float x;
Returns the arc sine of x, in radians.

- float atan(x);
  float x;
Returns the arc tangent of x, in radians.
• float **atan2**(y, x);
  float y;
  float x;

  Returns the arc tangent of x/y in radians. The result is between -pi and pi. Differs from just using the arc(x/y) because it can use the sign of each number to determine which quadrant to put the result in.

• float **cos**(x);
  float x;

  Returns the cosine x radians.

• float **hypot**(x, y);
  float x;
  float y;

  Return the Euclidean norm, sqrt(x*x+y*y). This is the length of the vector from the origin to point (x,y).

• float **sin**(x);
  float x;

  Returns the sine x radians.

• float **tan**(x);
  float x;

  Returns the tangent x radians.

• float **degrees**(x);
  float x;

  Converts the angle x from radians to degrees.

• float **radians**(x);
  float x;

  Converts the angle x from degrees to radians.

• float **acosh**(x);
  float x;

  Returns the inverse hyperbolic cosine of x.

• float **asinh**(x);
  float x;

  Returns the inverse hyperbolic sine of x.
float \texttt{atanh}(x);
float x;
Returns the inverse hyperbolic tangent of x.

float \texttt{cosh}(x);
float x;
Returns the hyperbolic cosine of x.

float \texttt{sinh}(x);
float x;
Returns the hyperbolic sine of x.

float \texttt{tanh}(x);
float x;
Returns the hyperbolic tangent of x.

### 13.5. Mathematical Constants

These constants are available for use in formulas in Cartographica:

- \texttt{pi}
  
  The mathematical constant \(\pi\).

- \texttt{e}
  
  The mathematical constant \(e\).

### 13.6. Geometric Functions

These geometric functions are available for use in formulas in Cartographica. To use them, you must always specify \texttt{geometry.function(parameters)}. For example, to obtain the area of the current geometry (valid only for polygons), you would use \texttt{"geometry.area()"}.

float \texttt{geometry.area(useBase)};

[bool \texttt{useBase};

Returns the area in the current coordinate system units, using either the map coordinates (\texttt{useBase} is 0 or not present) or the original layer coordinates (\texttt{useBase} is 1).

This function is only available for polygons.

float \texttt{geometry.length(useBase)};
Returns the length in the current coordinate system units, using either the map coordinates (useBase is 0 or not present) or the original layer coordinates (useBase is 1).

This function is only available for polygons and lines.

• float `geometry.bbox(useBase);`

Returns the rectangle of the bounding box of the current geometry using either the map coordinates (useBase is 0 or not present) or the original layer coordinates (useBase is 1).

The return value is a structure containing x,y,width, and height. To access each individual element, use the dot notation: `geometry.bbox().x` to retrieve the x coordinate, for example.

• float `geometry.midpoint(useBase);`

Returns the midpoint of the line in the current coordinate system, using either the map coordinates (useBase is 0 or not present) or the original layer coordinates (useBase is 1).

This function is only available for lines.

• float `geometry.centroid(useBase);`

Returns the centroid of the feature in the current coordinate system, using either the map coordinates (useBase is 0 or not present) or the original layer coordinates (useBase is 1).

This function is only for points, multipoints, and polygons.
Chapter 14. Color Palettes

Color Palettes are groups of colors that are put together to achieve some specific effect. For ramps (continuous color) the colors show a smooth transition across a range of values, highlighting fast rates of change. For segments (discontinuous color) the colors represent individual classes of information.

Cartographica has a sophisticated palette management system which provides tools to create, modify, import, and use color palettes in any part of the program that uses color.

Colors may be dragged from almost any source and Cartographica will import palettes from the ColorBrewer site (or anything that exports in a similar format).

Palette management is done through the Color Palettes Window, which provides editing and previewing capabilities.

![Color Palettes Window](image)

**Figure 14.1. Color Palettes Window**

The palette window is composed of two primary sections. The Palette List at the top of the window, which shows all available palettes that you have access to. The Palette Inspector at the bottom provides the tools to view the particulars of the palettes and make changes to them.

The Palette List shows the name and preview of each palette and a locked symbol if the palette is not editable.

The Palette Inspector shows the colors in the selected palette and whether the palette is Continuous (Cartographica interpolates out the colors in between) or Segmented (the colors are repeated in between).

To learn how to use palettes with vector and raster layers, see Procedure 6.7, “Applying a palette of colors to a set of styles” and Procedure 6.10, “Changing a Raster Layer’s palette”

**Procedure 14.1. Create a new palette**

1. Choose **Window → Show Color Palettes** to bring up the Color Palettes Window.
2. Click the Add (+) button to add a new palette.
A single color palette will be added to the bottom of the list.

Since the new palette is selected, the Palette Inspector shows the current colors in the palette and the Continuous button is selected.

3. Click on the name column and enter a new name for the new palette.

4. Click in the single gray-outlined box to add a new color to the palette.
   
   Always click here to add a color to the end of the palette

5. **Procedure 14.2. Removing a palette**

   1. Choose *Window ➔ Show Color Palettes* to bring up the Color Palettes Window.
   
   2. Click on the palette you wish to remove
      
      Palettes with the lock symbol next to them will not be editable or removable
      

   3. Click on the Remove(−) button

   ![Figure 14.2. Color Picker](image)

   **Figure 14.2. Color Picker**

5. **Procedure 14.3. Changing a color in a palette**

   1. Choose *Window ➔ Show Color Palettes* to bring up the Color Palettes Window.
   
   2. Click on the palette in the Palette List to select it
      
      The colors of the palette will now be in the Palette Inspector

   3. Click on the color once to select it
If the Color Picker is already up, the color will appear in it ready to be changed at this point

4. Click on the color a second time to bring up the Color Picker
5. Change the color using the color picker and the palette will change in unison.

**Procedure 14.4. Switching between ramp and segmented palettes**

1. Choose **Window → Show Color Palettes** to bring up the Color Palettes Window.
2. Click on the palette in the Palette List to select it
   - The colors of the palette will now be in the Palette Inspector
3. At the top of the Palette Inspector, click on the Continuous button (left) to change to a ramp color palette or on the Segmented (right) to change the interpolation method.

**Procedure 14.5. Reversing the colors in a palette**

1. Choose **Window → Show Color Palettes** to bring up the Color Palettes Window.
2. Click on the palette in the Palette List to select it
   - The colors of the palette will now be in the Palette Inspector
3. In the Palette Inspector, click on the reversal button to change the order of the colors.

**Procedure 14.6. Pasting a color brewer palette**

ColorBrewer [http://colorbrewer2.org/] is a well-known resource for creating meaningful palettes for maps. Cartographica can accept palettes directly from the ColorBrewer site for use in the Color Palettes Window. Although we specifically point at ColorBrewer for good palettes, Cartographica can import any combination of numbers where the Red, Green, and Blue components are separated by commas and have a range of 0-255 and where colors are separated by semicolons.

229, 245, 249; 153, 216, 201; 44, 162, 95;

1. Visit the ColorBrewer [http://colorbrewer2.org/] site to compose your palette
2. When you are done creating your palette, click **Export Your Colors** to bring in the export window
3. Copy the numbers in the box or just copy-n-paste
4. Switch back to Cartographica
5. Choose **Window → Show Color Palettes** to bring up the Color Palettes Window.
6. Choose **Edit → Paste** to past the palette into your Palette Window
7. Rename the color palette by clicking on the name and typing a new one.
Chapter 15. AppleScript Scripting

Cartographica supports scripting through AppleScript in order to control the program and add customize it for the functionality that your particular application needs. Support for scripting in Cartographica is extensive and it can be used to add, modify and delete Layers, Features, Columns and data related thereto.

Beyond support for basic data editing, Cartographica also provides scripting support for many of the built-in commands that are available for analysis.

15.1. Scripting Architecture

The Cartographica scripting architecture uses a standard AppleScript paradigm which can be used by any OSA (Open Scripting Architecture) compliant language to control and augment the application.

The primary object in Cartographica is a Document. Structured just like the Cartographica Mapset Document, the Document object contains a list of Layers. These Layers, in turn, contain various properties and a list of Features just like in Cartographica’s Mapset Document.

15.2. AppleScript Vocabulary

As is standard for AppleScript, the full description of the vocabulary is contained in the Application itself and visible to the standard AppleScript Editor (found in the Utilities folder inside of the Applications folder). We have summarized the main objects and their use in Table 15.1, “AppleScript Main Objects”.

Table 15.1. AppleScript Main Objects

<table>
<thead>
<tr>
<th>Document</th>
<th>Cartographica MapSet Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer</td>
<td>Layer in a Cartographica Document, used to store Features and dictate what they mean and how they are presented.</td>
</tr>
<tr>
<td>Feature</td>
<td>Feature in a Layer, used to store Geometry and Field Data for individual features.</td>
</tr>
<tr>
<td>Schema</td>
<td>An attribute of a Layer, used to store the Columns and information about the columns.</td>
</tr>
<tr>
<td>Style</td>
<td>An attribute of a Layer, the Style describes how the features in a layer are presented. Used to store Style Parameters.</td>
</tr>
<tr>
<td>Style Parameter</td>
<td>An attribute of a Style, the Style Parameter describes how a particular class of Features that are displayed using a Style are displayed.</td>
</tr>
<tr>
<td>Geometry</td>
<td>An attribute of a Feature, Geometry stores the geometric attributes of a Feature.</td>
</tr>
<tr>
<td>Column</td>
<td>Contained in a Schema, each Column describes a particular kind of data that is a part of the Feature’s definition within a Layer. The Column contains the type, length and other attributes.</td>
</tr>
</tbody>
</table>
Field Data are contained by a Feature and describe the values for a particular Column as it pertains to that Feature.

15.3. Example Scripts

This section contains some simple examples of what can be done with AppleScript scripting and Cartographica.

Example 15.1. Setting a column value for all Features in a Layer

tell application "Cartographica"
    set targetlayer to layer "Businesses" of the first document
    repeat with aFeature in every feature of targetlayer
        set value of field data "Copyright" of aFeature to "© 2010, ClueTrust"
    end repeat
end tell

The example above demonstrates cycling through every feature in the targetLayer (in this case a layer with the name "Businesses") and setting a value of the data field named "Copyright" to “©2010, ClueTrust”.